PDA

View Full Version : Pump Lock Lever


dballs
05-23-2008, 12:56 PM
This is a very minor issue, but thought I would ask anyway.

Just got a new 48" stander RH. Having a small issue with what appears to be the Pump Lock Lever according to the illustrated parts. When I put on the brake, the spring doesn't seem strong enough to pull that lever all the way down. As a result, it won't start without me physically reaching down there and pushing it down just a little bit more so it presses against the switch and starts.

Should I just get the spring replaced? Or is there some other tweak I can do to resolve the minor issue without taking it back to the dealer?

WrightCommercial
05-23-2008, 04:19 PM
dballs,

First thing to do is make sure the assembly is not to tight. There have been two set-ups for this assembly, the difference being what is used as the pivot point. On the early versions it is a welded pin on the later it is a shoulder allen bolt. Either version can bind if the washers used to space the assembly are to thick. There are two of these washers in the assembly, remove one and see if that solves the problem. Also there is a chance that there might some powder coat build up in the hole that the piece pivots on. Its unusual for the spring to be the problem but not out of the question, so if the first two checks don't solve the problem its possible the spring is out of tolerence.

Best Regards
Wright Mfg. Service Dept.

dballs
05-26-2008, 11:12 AM
WrightCommercial,

Thank you!

Darren