PDA

View Full Version : Electric hydraulic pump for dump?


Trhfire19
05-27-2008, 11:27 AM
I just installed a new electric/hydraulic pump on my dump. The unit is the ssame size of the old one. my problems are hydro fluid comes out of the vent when the dump is coming down, when the dump is all the way up it won't come down with pulling on the dump body, when going up towards the end, it sounds like it is out of hydo fluid. I called the manufacturer and when over all the hook ups with them. Everything is hooked up correct and they said it should work. I'm stuck and not sure what route to go. Any help will be greatly appreciated. Thanks guys.

Merlin300
05-27-2008, 01:56 PM
Sounds like it has air in the system. I would work it for awhile and see if it bleeds itself. I have a P.J. dump trailer that did the same exact thing when it was new. After a day of use, it worked itself out and runs perfect now.

Trhfire19
05-27-2008, 02:48 PM
Thanks Merlin for your response. I thought that the system was air bound also. I've been using the truck since Friday with no luck. I just have to go down a little at a time so it doesn't shoot out.

seabee1
05-27-2008, 02:54 PM
ditto on the oil ,do you have any bleeders on the top's of the hydraulic cylinders if you can get it up try to leave it raised for a couple hour's to let the air bubble's raise to the top ,then put a chock block under the back near the rear pivot,and crack the bleeder's on the cylinder's.if not just let it set and ad oil slowly to the capacity required to raise it fully without cavitating the pump

Petr51488
05-27-2008, 06:56 PM
I had the same problem with mine. It would leak out, like theres pressure in the tank when i let it down. And when i drove it this weekend for a few hundred miles, i found that the cap fell off and some of the fluid came out. I left the screw loose so it wouldn't build pressure. I'll try raising it and lowering it a few times to let the air out.

Trhfire19
05-28-2008, 10:08 AM
I've tried the suggestions you have made with no luck. Still shoots hydro fluid out when coming down. I let it sit overnite, tried going up and down a few times. Thanks for your help.

seabee1
05-28-2008, 10:37 AM
well the only thing i can think of ,maybe the return tube in the pump tank came off and is aerating the oil ,or you need a restrictor valve in line .i assume this is a single acting pump and oil returns back through the pressure line,and the same type and model pump with the same size tank . :confused:

mowingguy
05-28-2008, 03:50 PM
Trhfire, send me some specs on the pump and setup. We build dump trucks and have used electric pumps on some one tons.
Could be something simple. Is the fluid coming out of the cap vents?

Is the fluid full of "bubbles"? I can walk you through bleeding the system.
Did you use the correct sized hoses?

Often the reserve is filled too much and makes a mess.

Again send me a PM and I will try to walk through this with you. -SL

mowingguy
05-28-2008, 03:52 PM
Another question. Did the pump, sub frame and dump bed come as a kit? -SL

mowingguy
06-10-2008, 03:50 PM
Trh,
I have not heard from you via PM. Try these simple things then let me know.

Grease the rear pins on the subframe. "needing down pressure and not reaching full dump height" are usually caused by the pins binding.

The pump is probably fine and the correct size. Air is most likely being introduced while it is raising and lowering the bed. Therefore taking up more space. -SL

Drew Gemma
06-10-2008, 04:23 PM
adjust the valves

Also find the correct fil level on tank

raise the bed up and down over and over to work the air out

and fill as needed

elec over hydrolic sucks