PDA

View Full Version : Engine problems


mowerbrad
08-02-2008, 12:08 AM
Today while finishing up my last yard my engine started to act funny when I engaged the blades. Once I engaged the blades the engine started to go up and down in sound pitch and I felt as if I was losing some power. I checked the air filter, oil level to see if something wasn't right, but everything was fine. It has done this to me once before about 2 weeks ago. This engine has under 100hrs on it and has maintenance done on it regularly. The PTO clutch is bad on the mower so I don't know if that might be the problem or part of the problem. Any ideas what could be causing this?

mowerbrad
08-02-2008, 10:48 AM
Anyone know what might be going on here?

Big Wes
08-02-2008, 12:30 PM
1- change your fuel filter (more than likely will fix your problem)

2- remove float bowl and spray carb with carb cleaner.

ALC-GregH
08-02-2008, 12:43 PM
The PTO clutch can cause problems like you mention. I'd get that fixed/replaced and see if it continues. It could be slipping and causing the change in RPM.

Fuel filter is a cheap fix as well and can cause very similar problems but you mentioned the PTO being bad so if thats the case, I'd get that straight first. The fuel filter shouldn't get blocked up in 100 hours, at least I wouldn't think it would.

CkLandscapingOrlando
08-02-2008, 01:57 PM
I'd also check your ignition switch.My gravely just went through problems with the idle,pto,and after a while just staying on.All this with one bad contact