PDA

View Full Version : Battery going dead?


joallen001
04-22-2009, 10:30 AM
The other day while mowing one of our Hustler Super Z 27hp Kohler just died cruising down the yard. We jumped it off to get it back on the trailer and bring to the shop. The battery showed to be dead so we charged it and we cleaned the ignition coil which had lots of trash around it. Ok so mower is charged up and ready to go. So we sent it off on a crew to cut some more. Well the mower lasted about an hour. So we start over jump it off and bring back to the shop. This time we put a new battery on since the recharged battery took a while to get to charge up. Off to mow again!! Well yesterday the mower ran for about 4 hrs and the new battery was completely dead. Obviously it seems the battery is not charging. Hopefully this is enough description to get some ideas on fixing this mower. We decided to keep 3 of our super z's this year even though they are out of warranty. So far every one of them has given us some problems. One had to have new seals in the hydros, one had to have a new hydro pump, and of coarse this one now. They all have around 1500hrs. Thanks for all the help and suggestions.

topsites
04-22-2009, 10:37 AM
Yeah, I carry my mainline of tools in a box in the truck, along with more than a few spare parts.
Whenever possible I carry the spare mower with me, too.

Take yesterday, a C-clip broke, wasn't a big deal but the belt kept coming off the pulley.
Didn't have the spare mower now :p
And it cost me 1/2 hour but I fixed it right there, spare clip and all.

Yes sir, got tired of it.

DT Lawn Care
04-22-2009, 06:36 PM
You should check the alternator (the device that charges the battery when the motor is running). Either that or something is just sucking the juice out of it like maybe a bad ground or something? Probably not, but I can't really think of anything other than the alternator. GL

4.3mudder
04-22-2009, 06:52 PM
I would get a voltage tester or a test lead and see if you have current coming from the alternator when the engine is running. It sure sounds like it is not charging at all.

K/B
04-22-2009, 07:00 PM
It's not charging. The engine ignition uses battery power to run, thus since the battery isn't being continually charged, as soon as the battery drains the engine shuts off.