PDA

View Full Version : Kawasaki FH721V Governor Issues???


htr4
05-15-2009, 07:59 PM
Ok, so here's the issue I've got... I've got a 25hp Kaw on my Lesco Z-Two. It's been great up until this point. I was having issues with the motor running way up (43-4500 rpms) with no load...no good, and bogging down in tall grass. Finally, I ordered a new set of springs for the controls and governor. Also noticed that the hole on the governor lever was worn out so I put a new one of those on as well. Problem NOT solved. Put it all back together, still runs way up with any movement forward of the throttle control. Also noticed that there is NO feedback from the governor lever (on the motor) at all. On my JD, the governor lever pulls back when the motor runs up, this one DOES NOT... Bad news? Any ideas? I don't want my mower running this fast! Thanks a ton! Tom.

Restrorob
05-15-2009, 09:41 PM
Tom,

Sounds like you need to properly adjust the governor since replacing all these parts;


http://i107.photobucket.com/albums/m314/Restrorob/Kawasaki/FH/FH721DGovernorAdjustment.jpg



Good Luck

htr4
05-15-2009, 09:52 PM
I did all of those steps, have a service manual on the computer...only I used a pair of pliers instead of a "jig pin." I got the thing all the way counter clockwise and set it according to book. When it's running there is NO response from the governor at all. Internal? Thanks for the reply!!

htr4
05-15-2009, 09:53 PM
BTW - I replaced all of those parts because it was having this problem... Nothing's changed with the new springs. Thanks again!

Restrorob
05-15-2009, 10:00 PM
Internal?


Well, If adjustment has been made and the governor still doesn't function properly I suppose the next step is pulling the sump/pan and inspecting the governor it's self.

htr4
05-16-2009, 09:54 AM
ugh...that's what I thought. Fun fun. Thanks for the help! :)

btsayles
05-13-2011, 08:48 PM
Sorry to hijack a thread and so late, but can anyone tell me where I can find a manual for this engine? FH721V-BS15. Thank you guys!