PDA

View Full Version : Echo trimmer boggin down...ideas??


Natural Impressions
05-18-2009, 09:50 PM
I have an Echo trimmer, not sure exactly which one ( just don't feel like going outside to check) br340 or something. When I want to start it I always have to put the choke on and pull the rope until it starts and dies out. Then pull the rope with the choke open and hold full throttle. When it starts I usually have to play with the choke, open, close, open, close, until it has a steady rpm. Now I have to hold full throttle until the rpms go to full speed. And if at any time I let go of the throttle completely it dies out.

Not sure what the problem is.
New sparke plug, carb is clean, new air filter. Is the carb shot?
Any ideas would be great. Thanks

davidl79
05-18-2009, 10:29 PM
Could be a bad carb or a plugged up muffler. You might even have a gasket leak.

ed2hess
05-18-2009, 10:34 PM
I never had a carb go bad........they can be rebuilt but that is not the problem. Be sure spark arrestor is out and then take the muffler off and clean the ports. Then take the starter rope assembly off and try to see if any fuel is coming out around the crank shaft or the cyclinder head. Those crank seals come out after the units get older.

Natural Impressions
05-18-2009, 10:54 PM
I never had a carb go bad........they can be rebuilt but that is not the problem. Be sure spark arrestor is out and then take the muffler off and clean the ports. Then take the starter rope assembly off and try to see if any fuel is coming out around the crank shaft or the cyclinder head. Those crank seals come out after the units get older.

The spark arrestor is the screen on the muffler right? I have taken that off and it was clean but I have to check the muffler itself.

And if fuel is coming out around the crank shaft, how do I fix thats?