PDA

View Full Version : 2004 gmc 1500 4x4 xcab cabin fans not working


mower&more1986
05-19-2009, 01:01 AM
ok the fans in my truck arnt working anymore. it started with lowest speed going bad then the others as i switching off about 6months down the road.
so a friend thought it was a fuse but i checked the ones in the cab but i may need to check again. im wondering if its a switch but idk. atm i cant afford to take it in the dealer have it checked out.

Columbia Care
05-24-2009, 09:54 PM
Take the truck to a chain store (Auto Zone or Advanced Auto Parts) and have them check the heating and air blower motor. If it test bad, they can guide you on the best way to change it out. If it is OK, they can also guide you the next steps to take to solve the problem. It will be less expensive than the dealer or a local repair shop. Good Luck!

4.3mudder
05-24-2009, 10:04 PM
If it started with one speed and went to the other speeds over time it sounds like it might be the switch going out, or in this case might be shot.

corey4671
05-24-2009, 10:15 PM
wife's trailblazer did the same thing. Uses the same parts...hate to tell you this but it is the switch and if you take it to the dealer it'll cost you about $300 to replace.

4.3mudder
05-24-2009, 10:19 PM
You should be able to replace the switch yourself. I would look on ebay or amazon for one. I know the Chevy parts house will want boo koo money for it.

corey4671
05-24-2009, 10:21 PM
I stand corrected. My problem was more than the switch. I'll have to find the receipt to tell you exactly what it was.

JKOOPERS
06-08-2009, 09:03 PM
was it the resistor?