PDA

View Full Version : Toro 21inch governer trouble


xxl
05-19-2009, 07:25 PM
I have a toro 21 inch mower and when i engage the blade the governer dose not move to compesate for the load on the engine. When i move it manualy it dose fine but it will not move by its self. I did change the blade belt and pulley those are brand new


Mower info
toro
Super recycler
Engine Gts 5 6.0 hp ohv
Model# 20483
Serial# 7903064

I think i covered it but if not please ask and i will try to find the info

Restrorob
05-19-2009, 09:43 PM
Sounds like you need to check/adjust the governor seeing if that solves the problem, Procedure below.....


1. Loosen screw holding governor arm to governor crank.

2. Rotate throttle plate linkage from idle position to full throttle position.
Note direction of rotation of the governor arm attached to the throttle
linkage.

3. Place and hold the linkage in high speed position.

4. While holding the linkage in this position, Use a approprite tool to rotate
the governor shaft until it stops in the direction noted in step 2.

5. tighten screw holding governor lever to governor crank. Torque to 35-45
in. lbs. (2.8-5.0 NM).

6. Before starting engine, Manually actuate governor linkage to check for binding.


Good Luck

xxl
06-03-2009, 03:03 PM
tried resetting the gov it is still hesitating when i engage the blade and cutting grass

Restrorob
06-03-2009, 09:10 PM
Did you perform step 6 ?

It's not uncommon for carb throttle shafts to gum up from sitting and or sand getting between the shaft and carb body causing them to stick/hang up.

Double check this and all linkages then it wouldn't hurt to spray some type penitrating lube on them.


When you move the throttle control from idle to fast doe's the engine speed up really fast/quickly ?

mowerknower
06-03-2009, 11:26 PM
Make sure the governor linkage is not binding anywhere.

xxl
06-04-2009, 10:41 PM
big thank you to Restrorob resetting the gov worked. the orther problem was the parts shop gave me the wrong belt but it was in the right wrapper and looked close to what i needed . So my mower is running tip top:) Thank you to
mowerknower for your input