PDA

View Full Version : 2004 gmc 1500 4x4 cabin fans not working


mower&more1986
05-21-2009, 04:26 PM
ok the fans in my truck arnt working anymore. it started with lowest speed going bad then the others as i was switching them on about 6months down the road.
so a friend thought it was a fuse but i checked the ones in the cab but i may need to check again. im wondering if its a switch but idk. atm i cant afford to take it in the dealer have it checked out.

freedm2
05-21-2009, 05:03 PM
Do you have auto climate control or manual?

If its manual it sounds like the POT has gone bad. Think volume control on a stereo.

mower&more1986
05-21-2009, 05:06 PM
manual and thank you for the respones. any ball park idea what it could cost to fix

Mike Fronczak
05-21-2009, 06:04 PM
If its the same as my wifes trailblazer it is a resistor switch. Did same thing hers now works only on high. New switch was $ 80. I've had it for 3 months now, we'll see if I ever get time to change it.

rwar
05-21-2009, 06:11 PM
look under the dash on the pasenger side,follow the wires to where it plugs into a connector by the blower motor,my 05 gmc melted the wires there,there is a big resistor under that connector its probably bad

SfTD_service_CENTER
05-21-2009, 06:19 PM
resistor easy fix napa auto parts has them instock usually for chevy, gm. common issue have any problems come back here im sure any people who have done them can talk you through it, or ask a napa parts guy some of them have the knowledge to help.

dta1984
05-21-2009, 07:04 PM
Yep, its the blower motor resistor. It was a $40 part at Advanced. I have an 02 Silverado, and it was an easy fix. It is located under the dash on passenger side. Seems like one of the black plastic air ducts had to be removed, but after that its just plug and play.

mower&more1986
05-21-2009, 11:56 PM
thank you for the response and i take a look tomorrow mourning

topsites
05-22-2009, 12:26 AM
Not that particular problem but I've fixed mine with parts from Ebay before.