PDA

View Full Version : 14sx commercial john deere


grasscutt
04-02-2002, 07:14 PM
i have two 14sx 21 inch commercial mowers that i use for small front and back yards. here is the problem. When I make a pass with the mower it is leaving stagglers that make my job in complete. so I either have to double cut or do trim work that is unnecssary. I frequently sharpen and balance blades but it still does this. i purchased new blades same problem. I usely cut high for residential 3-3.5 could this be the problem. Walk behinds don't have this problem. help....

Kevin
04-02-2002, 07:42 PM
Make sure the blade bolts are tight. Are u bagging? Discharging?Where did you buy your mowers from, maybe a local JD dealer can help.

grasscutt
04-02-2002, 07:54 PM
i always bag clippings. i bought them at a john deere dealer. changed blades and bolts are tight

AK Lawn
04-02-2002, 08:03 PM
i have had the same problem from time to time on my 21inch Honda's interested to find out how wto fix as well?
AK Lawn

Kevin
04-02-2002, 08:13 PM
May have to go a little slower, that might help.

rodfather
04-02-2002, 08:31 PM
Maybe try a different type blade depending on conditions...high lift in wet or long conditions, or a mulching blade when the occasion arises.

Greenstar Services
04-04-2002, 02:07 AM
Adjust your speed. You may be going to fast for the terrain. Also what we do is always have the rear wheels on the mower 1 setting higher than the front. If you notice on an Exmark walkbehind the rear of the deck is slightly higher.2 Years ago I had a rep from Exmark point this out. It makes for better bagging and mulching.