PDA

View Full Version : Plate Compactor Problems


CALandscapes
07-07-2009, 06:44 PM
We recently bought a used Mikasa 5200 lb. plate compactor, and are having some issues with it. The engine runs fine (now that we put a new air filter on it; the old one was gummed up), but the machine isn't pushing nearly full strength (it's hitting softer than a 1500 lb. Wacker).

I'm hoping that some of y'all may have some suggestions so that we can locate and fix the problem.

Thanks in advance.

-Chase

P.L.
07-07-2009, 10:22 PM
check the oil in the vibrator

DVS Hardscaper
07-07-2009, 11:22 PM
check the belt tension, as well as the centrifical clutch

CALandscapes
07-09-2009, 06:28 PM
Figured it out; the belt was the wrong size, as well as the bearings need to be replaced. We switched out the belt, but need to order the bearings. This brings me to my next question:

The machine, a Mikasa (Multi-Quip) 5200 lb. reversible compactor, still isn't hitting as hard as the Wacker 1040 that we had been renting... I'm curious how a machine rated so much higher could still be underpowered in comparison; am I missing something?

Thanks again for the help!

-Chase

DeereHauler
07-09-2009, 11:48 PM
how do you know its not performing to its fullest if the belt was wrong and bearings are bad, i would make the repairs then gauge it from there. If it were me i would take it to my small engine guy and have it gone over. Make adjustments to rpms, or carb as needed. If it was used, it was most likely used hard, and put away dirty, so it may need some attention beyond an air filter.