PDA

View Full Version : 2000 pm260z 60"


Stinger
04-21-2002, 09:24 PM
I own a 60" promaster 260 Z rider (2000 model) and can't seem to remove the center blade bolt. I have soaked the proper area with penetrating oil overnight and tried removing first with a 1/2" air impact and then a 3/4" with no luck. Then I applied heat to the bolt and tried the 3/4" impact again and still would not budge. I am guessing that my guys hit a rock really hard or something because the blade bolt is frozen stiff. I am in fear of trying a 1" impact due to the extreme force that could shear the head of the bolt off. Can I gain access to the bolt through the top of the spindle? Any suggestions or input would be greatly appreciated, Thanks!

Stinger
04-23-2002, 09:18 PM
Well I went for it and tried the 1" impact and it worked without any damage to the unit. Now I have a left side wheel motor pump leaking fluid. I've checked the hoses, and all connection fittings were tight with no leaks. I guess they sell a gasket kit which is all I probally need. This unit has only 433 hours on it man I dont understand what could cause this problem with such few hours on the machine.

The Gladiator
05-07-2002, 02:53 PM
Stinger,

As with anything as time goes by the manufactures tend to improve on there design. Hydrogear has changed from using a paper type gasket to an O ring type seal. When you replace the gasket make sure to use a high quality sealer on both sides of the gasket. That should take care of your problem.

Regards,
Dan Kilgas