PDA

View Full Version : Kohler 730H (25 HP) High Speed Miss


digger23
08-25-2009, 04:41 PM
Hi, first post here. I hope someone has run into this before. I am tearing my hair out.

I have a little hydraulic loader equipped with a horizontal shaft 25 horse Kohler Command Pro twin. The engine misses at high speed, but only when it's hot. The engine doesn't shake like you would expect with only one cylinder missing. It acts like both cylinders are experiencing the same problem. and it feels more like a fuel than electrical problem.

The old plugs had a little bit of fluffy carbon on them. I've changed the fuel filter and the plugs. I verified the fuel pump is working. The fuel is fresh. The air filter is fine. There is no unusual mechanical noise. The oil level is spot on. The engine starts immediately and low idle is fine. When it is cold, no load high idle is fine. When it is hot, it's not. Putting a load on when it's hot makes it worse.

Any ideas, other than ordering a carb kit and installing it?

Thanks.

Shasta Lake Landscaping
08-25-2009, 04:45 PM
Did you pull the carb apart and clean it?

digger23
08-25-2009, 04:59 PM
No, not yet. I won't take it apart without a kit on hand, and I have to order it. It's the temperature sensitive part of this that I don't understand, and really that's why I posted. I'm hoping for a clue as to what is going on.

Restrorob
08-25-2009, 07:13 PM
Here is where a couple in-line spark testers would come in handy, You could then watch the ignition while acting up and see if it is at fault or fuel related.....

digger23
08-25-2009, 09:11 PM
I know. I was cussin' myself for not having anything like that laying around. I haven't had any kind of ignition trouble in years, so haven't really kept the tools for working on those kind of problems. I still don't think I have ignition troubles, but it's an easy check to make sure. I plan to pick one or two up tomorrow.

equipmentsolutions
08-26-2009, 08:04 PM
Yah I would go down the coil/ ignition check first just based on the fact that you say it happens when it gets hot. check that and go from there. You can also possibly determine if you have a fuel starvation issue by giving it some partial choke when it starts to die to see if it runs better.