PDA

View Full Version : BadBoy Cut Problems


cj4
09-11-2009, 01:33 AM
Is anyone having problems with their Badboy leaving hairy blades of grass and having to go over it twice???? I've had mine for just over a year now and it's done it since it was new but I attributed it to probably dull blades. I don't think this is the problem because I had a guy who mentioned the same problem with one that he has rented a few times as well. And mine has done it since it was new. Other than that, I love my Badboy but this has got to be fixed. I thought I'd give this forum a try before I pound the dealer.

lawns Etc
09-11-2009, 01:49 AM
Sharp blades will make a big difference but the pitch on the dech needs to be checked.
Set the deck up with all blades facing front to rear and measure the blade tip to ground at the front adjust till they are all the same then go side to side you should have the same on each side of the deck and the rear should be about 1/4 " higher than the front blade tip. I made up 2- 3" blocks and 2- 3 1/4 blocks to adjust the blades to. You cant use the deck as the manual says because it may not be square and level itself. As you adjust the deck keep checking the measurements as every adjustment will affect all angles. Mine was not cutting as good as it could until I got it leveled.

unkownfl
09-11-2009, 01:52 AM
Try slowing down.

cj4
09-11-2009, 02:35 AM
I've tried all speeds, all heights, full throttle always, etc and it doesn't affect it at all. Still the same. I haven't tried adjusting the deck though. I will try that. That sounds pretty difficult to me but i'll try it. thanks

12thKY
09-12-2009, 02:02 AM
Switch to the ExMark (excaliber) notched high lifts. It will cut ALOT better. The only thing I have trouble with is clover heads, but then again every mower I've ever had had trouble with them to.

h0mr12
09-12-2009, 02:42 AM
How bumpy is your ground you are mowing? My deck was way off from the factory also but that just left an uneven cut. I noticed alot of the scragglers were from going over bumpy terrain too fast.

Do you know 12thKY if these blades will work on my 60 inch badboy diesel?

http://cgi.ebay.com/6-Oregon-91-264-Mower-Blades-for-Exmark-103-2530-Lazer_W0QQitemZ280393326692QQcategoryZ82248QQcmdZViewItem

brucec
09-12-2009, 02:51 AM
I run the exmark hi lift blades on my 60 " Bad Boy with the 5/8 center hole. MUCH better than the stock blades. Also what are your rpm's at?

brucec
09-12-2009, 02:54 AM
I think the blades in the link above are the stock BB blades even though they say exmark. I know because I order the oregon exmark fusions and the were the exact stock blade that comes on the BB. I would like to know if exmark makes an extra high lift blade, I'd really like to try that

cj4
09-12-2009, 09:31 PM
I think my blades are some kind of super duper blades because when I bought it the dealer was all into these blades........so I think they are the blades you guys are talking about. Again, I've tried all speeds, my rpms are most always wide open, and it does it on any kind of ground. It's gotta be the deck adjustment.

Talked to the dealer today and he wanted me to bring it in. I threw a belt today (first time ever) and when I put it back on, it kept twisting on me so we figured it messed up the belt and I need a new one. I'm also having him plumb some kind of extension or tube on the oil drain because this 31hp is a mess when you pull the oil drain plug. It runs all over that rear deck and that's senseless. He's a great concerned dealer and he wanted it in so he can get to the bottom of this cut problem. I'm really thinking it may be the deck out of adjustment but we'll see.