PDA

View Full Version : Ferris Dual drive, can't get hydro bypasses to work correctly


LaborFriendly
09-12-2009, 05:14 PM
Hi I've got an 05' 52in. 17hp. dual drive walk behind and when I engage(pull up and lock) the hydraulic bypass levers only the right wheel spins freely. The bypass valves are both adjusted equally. I've played with the left bypass range of motion and at no time does it let up on the motor pressure, thus allowing free wheel motion. I've looked through the online manual and the only thing I can come up with is perhaps re-adjusting the drive motors "neutral" positions. The mower tracks straight. I can start the mower to move it but I would prefer to get this fixed as I do most of my maintenance in the evenings and don't want to bother my neighbors moving my mowers around. Any help would be much appreciated, thanks....D



Exmark 48in. Lazer Ct, great sept for the rear tires : /
Ferris 52in. dual drive w/ velky
MTD 36in. belt drive Walk behind w/ velky
Shindaiwa 242 and 231 multi-tools
Stihl Bg-86 Handheld blower

pugs
09-12-2009, 10:44 PM
That is odd...most of the old ones that come in for service have the rods missing so nothing to pull up on. Ugh, PITA.

I would have to look at an eaton breakdown and see how that bypass even works.

Sounds like you are sure its being pulled up far enough so I would think its something internal :(

LaborFriendly
09-12-2009, 11:06 PM
Yea, I'm sure. If you take the belt guard off the deck you can see the levers, and watch as you pull the rod up. As I said, it's adjusted same as the other side. It's a threaded eyelet that threads into the side of the motor, via I'm not sure what to call it, but that part turns and is what opens closes the relief valve. I took the top rod off, so I could fully move the eyelet through it's full range of motion and still nothing. Again the mower tracks great and the hydro motors seem strong. I did pick it up used and don't have that much of a history. I've cut alittle less than a dozen times with it, fresh oil, plugs, air filter and precharger and it runs like a top. I've yet to change the hydro oil but intend to soon. Thanks for the response and any followups guys!