PDA

View Full Version : 2 cycle kicks back


JPL
09-14-2009, 04:54 PM
I have a Sthil Concrete saw TS510 (older model) when I try to start it the pull cord it is very tough to pull, when I over come the force the cord kicks back. I can get the saw to run but it's only a mater of time before the cord pulls my arm out of the socket.
Is this a timing issue with the key on the fly wheel?? or is there something else I need to look at ?? The saw is a two stroke so there is no valves to adjust.
Please advise what I need to do.
Thanks

Breezmister
09-14-2009, 07:46 PM
I have a Sthil Concrete saw TS510 (older model) when I try to start it the pull cord it is very tough to pull, when I over come the force the cord kicks back.

If your saw has a compression release, it's sounds like it's not working
I know that the TS 400 and 420 have one so that is where I would start.
You can replace it, or if you want to, oil it up with some PB blaster and work it up and down to free it up, if it's not to dirty.

JPL
09-14-2009, 08:54 PM
The saw is A TS510 and does not have a compression release.What I have done so far is basicly stripped the machine to the bear mimimum with the muffler removed.
With only the spark plug in when I pull the cord it is very strong just before TDC. I have checked the compression and I get a reading of 125psi.

ericg
09-14-2009, 09:05 PM
Just a thought. Could there be too much carbon on top of the piston which would increase the compression ratio causing difficulty pulling the cord.

Eric

JPL
09-14-2009, 11:05 PM
I will check the carbon build up on the piston in the AM that was on my list and the only thing left.
I will report tomorrow I am still open for any other ideas.

SLR
09-15-2009, 01:13 PM
Almost sounds as some kind of hydro lock up is going on(to much gas in cyl)

JPL
09-15-2009, 10:30 PM
I broke down the engine today and looked at the carbon build up on the piston and the top of the cylinder housing. I thought well that's not too bad. I cleaned the piston and the housing put it all back together and tried it and low and behold it worked. Now when I pull the cord it works like a new machine. I am now a believer... I now need to adjust the carb. the saw is now running too fast. I had take photos of the carbon build up but I left my camera in the shop so I will add them tomorrow.

hate2work
09-15-2009, 11:43 PM
I broke down the engine today and looked at the carbon build up on the piston and the top of the cylinder housing. I thought well that's not too bad. I cleaned the piston and the housing put it all back together and tried it and low and behold it worked. Now when I pull the cord it works like a new machine. I am now a believer... I now need to adjust the carb. the saw is now running too fast. I had take photos of the carbon build up but I left my camera in the shop so I will add them tomorrow.

I've started using Amsoil Power Foam to melt away the deposits on the piston crowns, that stuff is magic. It could have saved you the trouble of tearing it down to clean it.

Something else that could help you is to put on an elast-o-grip starter handle. The part # you want is 1122-190-3400 for that machine.

ericg
09-16-2009, 06:22 AM
Glad to hear that the carbon build up was the cause which was an easy fix.
I have had this same issue with our machines. Its funny how certain machines favor one brand of 2 stroke oil over others.


Eric

hate2work
09-16-2009, 08:25 AM
Glad to hear that the carbon build up was the cause which was an easy fix.
I have had this same issue with our machines. Its funny how certain machines favor one brand of 2 stroke oil over others.


Eric

In many cases the oil is to blame, but these cut-off saws run very rich by design and that is a big contributor to the problem. Especially these older ones that are simply chain saws converted over to a belt drive, with the canister air filter and a larger high speed nozzle stuck in the carb. We're not seeing this issue very often with the newer saws, especially when they use the Ultra oil.

JPL
09-16-2009, 09:57 PM
As promised what carbon build up looks like and causes problems.
After cleaning the saw now runs great.:cool2:

hate2work
09-16-2009, 10:40 PM
Nicely done!! :clapping:

I hope you put that arrow up towards the exhaust :eek:

BTW, you can put a comp release on that saw, most often they were just plugged with a threaded insert. But it's much easier to do when you have the back shroud off.

Again, very nice job :)

ericg
09-17-2009, 06:20 AM
Nice pictures. It goes to show that it does not take a lot of carbon to screw up a two stroke. Many times when performing mtce, we scrape the carbon off through the exhaust port to prevent having to disassemble the piston from the barrel.


Eric