PDA

View Full Version : Quick Disconnect Fittings


RAlmaroad
09-16-2009, 06:40 PM
I use quick disconnect brass couplers on my reel and hose connections. Brass was all that I can find. They are always sticking even though I use WD-40 each time I clean the lines out. I've even replaced a couple of them as they were frozen. I've not seen any Stainless Steel. Any advise or knowledge to prevent happening or remedy? Thanks

CHARLES CUE
09-16-2009, 09:30 PM
WD 40 only last about 40 secs look for some thing different that will last and stay on the surface
A lot of people on here like fluid film i have never used it i use something different product
Charles Cue

Ric
09-18-2009, 02:09 PM
I use quick disconnect brass couplers on my reel and hose connections. Brass was all that I can find. They are always sticking even though I use WD-40 each time I clean the lines out. I've even replaced a couple of them as they were frozen. I've not seen any Stainless Steel. Any advise or knowledge to prevent happening or remedy? Thanks

Roy

I agree WD 40 lasts about 30 seconds. I use Vaseline or Lithium Grease. But the bottom line is fast snaps don't last forever and need replaced. I used to be able to get Brass with a SS release ring at a much higher cost. The release ring is what gets bend and causes the main problem.

Bigred350
09-18-2009, 05:41 PM
Use Fluid film.

RAlmaroad
09-18-2009, 07:25 PM
Didn't really think about how fertilizer, fungicide and herbicide would corrode these components in the beginning. Just today changed them out to brass pressure washer couplers with SS ball bearings and retainer rings and Nitrile seals. The originals have gone through many gallons and have done well till now. Can't complain and hope that these new ones, though real expensive, will work out. Thanks.

phasthound
09-18-2009, 09:09 PM
Guess I'm lucky, my local hydraulic repair shop has SS quick disconnects that cost less than the brass ones.

FERT-TEK
09-19-2009, 12:16 PM
Roy

I agree WD 40 lasts about 30 seconds. I use Vaseline or Lithium Grease. But the bottom line is fast snaps don't last forever and need replaced. I used to be able to get Brass with a SS release ring at a much higher cost. The release ring is what gets bend and causes the main problem.

Hey Ric, good to see you are posting again....I followed that ridiculous thread for a while.
Regarding the quick connect threads I may purchase a Z-Spray Jr this off season and have been daydreaming about making a a quick disconnect system for its aux tank. The ones that can be added to fert trays behind the drive wheels. By making a reliable quick disconnect system that doesn't leak an applicator could carry several spare tanks for certain apps (drive, fungicides, insecticides etc.) and switch them as needed. Having said that a Z-spray set up with two tanks should be enough. The main tank for your weed control and the aux tank for seasonal issues but still wondered if it would work. Have you found that they failed due to corrosion or because of not having enough pressure to seal them?

americanlawn
09-19-2009, 09:30 PM
ditto with FERT-TEK. It's nice to see Ric here (good man for sure). I've been using a stainless steel male w/aluminum female coupler since 1990. They seem to last for 2 to 4 years. I can interchange lawn guns (TeeJet), J-D9 guns, and tree rifles. All interchangeable.

Regarding quick-disconnect fittings + ride-ons....TURFCO has already solved this. These fittings allow for fast filling, as well as an "easy on/easy off" auxillary tank. Pics will follow once TURFCO posts pics or else from me (when I get the okay), cuz Turfco has several patents pending. Lots of improvements for the 2010 T3000.

GO HAWKEYES! :usflag:

americanlawn
03-03-2010, 08:01 PM
Sorry I have not posted these pics earlier. Took these pics today cuz manyl have expressed interest in the 16 gal aux tank for their T's. (Right side saddle tank has a quick disconnect fitting for fast filling). Left saddle tank is fed from above by the 16 gal aux tank (w/quick disconnect fitting). T3000 in the pic has about 600 hours on it.

Last year we just placed the 16 gal tank in the carrier tray (as seen in pic 1). But we plan to remove the tray (when needed) and bolt the tank (4 bolts) right into the stainless steel frame cuz the female threads on the aux tank match up perfectly (see bad pic #2 with the aux tank placed on its side in front of the frame rails. You can barely see one of the metal female threads in the bottom of the tank). That way there will be no movement of the aux tank whatsoever compared to how we did it last year.

We also plan to change the aux tank plumbing -- better way is to install a "T fitting" in front of the left saddle tank (return hose).

I think TURFCO now offers these features, but I'm not sure how they do it. All I know is we've been busy showing our '08's & 2010 T's to several guys in the Midwest -- I also hope this post answers questions & minimizes PM's.

I'll post pics of our light weight twin receiver carrier racks soon when we finally get 'em (been bumped by other T3000 purchasers). Seems most interest is with our "aux tank" & our "carrier racks". BTW when guys see our 2-year old units, they often ask "Where's the rust?" Then they ask about the engine. Answers: 1) There ain't no rust. 2) Engines still run like new, and use no oil whatsoever. Then I tell 'em, "If my brother-in-law can't wreak it, it's bullet proof". :laugh: Again, thank you for your patience.

grassman177
03-03-2010, 08:29 PM
Hey Ric, good to see you are posting again....I followed that ridiculous thread for a while.
Regarding the quick connect threads I may purchase a Z-Spray Jr this off season and have been daydreaming about making a a quick disconnect system for its aux tank. The ones that can be added to fert trays behind the drive wheels. By making a reliable quick disconnect system that doesn't leak an applicator could carry several spare tanks for certain apps (drive, fungicides, insecticides etc.) and switch them as needed. Having said that a Z-spray set up with two tanks should be enough. The main tank for your weed control and the aux tank for seasonal issues but still wondered if it would work. Have you found that they failed due to corrosion or because of not having enough pressure to seal them?

that tank changing system is a darn good idea. i like that