PDA

View Full Version : scag wont start and at an account now...


delabarre
09-17-2009, 05:29 PM
I have a scag turf tiger and i got off it to talk to the owner of the house... i turned it off and put the brake on and turned the pto off when i trued starting it nothing happens... the only time i can get it to click is by having the deck engaged... any ideas?

AAALOUIE
09-17-2009, 05:31 PM
The starter clicks or you hear a relay click when you try to start it..... Double check the plugs at all of the safety switches....

skeet
09-17-2009, 05:41 PM
When finished mowing turn off the pto 1st, idle down for a few minutes and let the engne rest at an idle, set the handles at far width, put the brake on and turn-off... as I was told by the dealer

vaughnslawns
09-17-2009, 06:27 PM
fuse?.........

hondarancher4435
09-17-2009, 07:00 PM
try jumping the starter moter

The Captain
09-18-2009, 01:12 AM
I just had to replace the seat safety and neutral switches (both sides). I had no clicking or anything. It was if I were setting on a kitchen chair. Sounds like you have a starter relay problem.

I hate electrical problems because I usually can't see the problem, until I touch the wrong wire. Then I can't see anything......

Good luck.

AmGreen
09-18-2009, 06:39 AM
Hoping that you're not still at the customers yard - haha, but did you get everything back up and going? I was thinking maybe the handles hadn't been pushed out all the way. Had this happen one time, and fooled with the stupid thing for 10 minutes. When I finally realized what it was, I felt like an idiot.:hammerhead:

LilRabbit
09-18-2009, 07:25 AM
I had this happen too. Check the fuse and connections by the left side of the seat.