PDA

View Full Version : Hydro Pump


mowerbrad
09-19-2009, 03:50 PM
Well today as I began my work day, I was going over (checking oil, cleaning air filter, etc.) my Bob-Cat mower and found that one of the hydro pumps is leaking a pretty good amount of fluid. The fluid has leaked all around the pump and on to the ground. I've never had to have a pump replaced/serviced before. The mower has 1300 hours on it and never had a pump replaced, so it wouldn't shock me if it had to be replaced. Since I'm no expert with the hydro pumps, I don't know if it needs to be replaced or if a gasket just came loose and leaking now. I know a hydro pump will probably cost me $600+/- if that is the problem.

So with that description of the problem, what would be the possible diagnosis for the pump?

crawford_d
09-19-2009, 04:32 PM
Hydro Service
202 N Main St
Roland, IA 50236
515-388-4096

Even if you don't want to use the mail they will tell you exactly what you should have done one way or the other for free.

cbegap
09-20-2009, 05:26 PM
Can you narrow down where the leak is coming from? I had one of my pumps off and took it apart. There isn't that much to them inside and therefor not super difficult to work on. Main thing is keep everything really clean. Most pumps leak from the fittings, so try tightening those first and then dig into the pump.

mowerbrad
09-21-2009, 06:52 PM
Can you narrow down where the leak is coming from? I had one of my pumps off and took it apart. There isn't that much to them inside and therefor not super difficult to work on. Main thing is keep everything really clean. Most pumps leak from the fittings, so try tightening those first and then dig into the pump.

The leak is coming from the bottom of the pump, thats as far as I can see. All the fittings on the hoses are tight with no fluid around them.

It's at my dealer right now getting fixed, but I'm trying to decide what to do with the mower right now. Dealer said it could just be a seal or could be a bad pump. It's the first time any of the pumps would have ever been replaced, so if this one will be replaced, I figure the second pump isn't too far behind.

cbegap
09-22-2009, 08:03 PM
Sounds like an input shaft seal. Question is, what made it go bad? Did the seal fail or the bearings that then let the shaft rotate out of round and wear out the seal. I would be interested in knowing what the dealer says. There is more incentive to replace the pump from their point of view than if you worked on it yourself. They make money on the new pump, and there is less chance the mower will come back with the same or related problem. Same labor cost for them or maybe less because they don't have to open the pump. I can't blame them really, it is a pain to work on something for someone and not have it last, then they bring it back and you have to work on it again at no charge. I would venture a guess though that you could rebuild one a lot cheaper than buying a new one assuming nothing is really messed up inside. Let us know the verdict.

ed2hess
09-22-2009, 10:01 PM
Sounds like an input shaft seal. Question is, what made it go bad? Did the seal fail or the bearings that then let the shaft rotate out of round and wear out the seal. I would be interested in knowing what the dealer says. There is more incentive to replace the pump from their point of view than if you worked on it yourself. They make money on the new pump, and there is less chance the mower will come back with the same or related problem. Same labor cost for them or maybe less because they don't have to open the pump. I can't blame them really, it is a pain to work on something for someone and not have it last, then they bring it back and you have to work on it again at no charge. I would venture a guess though that you could rebuild one a lot cheaper than buying a new one assuming nothing is really messed up inside. Let us know the verdict.

So wouldn't you guess it is a bearing that is gone .........and seal got damaged? That is what happens on the drive motor. I got a pump sitting in the shop that I replaced last year and havent' opened to see what happened. If it is a bearing do you have to have special puller to get them out?