PDA

View Full Version : Help! JRCO Aerator problems


sollyj
09-22-2009, 08:50 PM
I was scheduled to start aerating tomorrow. I bought brand new last year the jrco aerator with the electric lift(used all of 8 hours last year), put it away, worked fine.... This year, the actuator wont work, just hear clicking, any ideas, connection look good .....Im stumped... need help!! anybody ever had same problem?? I need to fix this by tomorrow, heads are all flagged!

jc1
09-22-2009, 09:49 PM
We removed the actuator and use a strap to hold it up for loading and unloading the trailer. once on the lawn drop it and go.

sollyj
09-22-2009, 10:14 PM
so did you find out why the actuator wasnt working? Iguess if i have to strap it i will, but man its B.Sht spend that kind of money for 8 hrs use, and you gotta strap it

JRCO
09-24-2009, 01:41 PM
Sorry I haven't checked the forum in a couple days. Have you called us yet? Please do. I know we can help you.

Yes, the short term solution is to just pull the clevis pin and drop the heads down for aerating. You wouldn't need to lift it to turn or anything so that would get you through the job.

But please call us so we can help you. 800-966-8442. That's what we're here for.

Thanks,
Bill Radintz

sollyj
09-24-2009, 09:54 PM
I posted this after your business hours, took the unit to my local dealer, overnighted new actuator. I have the new actuator on it seems to work good, I hope it lasts a lot longer than the other. I have electric winches that have been really abused snowplowing and they are still working after 15 years. Hopefully, I just had a flawed unit, you guys(Jrco) have some descent products, all my other jrco pieces have held up very well!

JRCO
09-25-2009, 11:21 AM
Just did a search and see we overnighted a replacement motor for your actuator Wednesday.

Jim D requested your old motor sent back to us for analysis. I'm sure he'll figure out what's up with it. I'll keep an eye on this personally.

Sorry you had some trouble. Keep me in the loop if anything else comes up.

Thanks!

Bill

LawnGuy73
09-25-2009, 05:55 PM
Just did a search and see we overnighted a replacement motor for your actuator Wednesday.

Jim D requested your old motor sent back to us for analysis. I'm sure he'll figure out what's up with it. I'll keep an eye on this personally.

Sorry you had some trouble. Keep me in the loop if anything else comes up.

Thanks!

Bill

Sorry, not to hijack the thread or anything here. I think it was Jim I talked to at Minnesota Maintenance Equipment's open house this morning, great guy and very informative We have been running your JRCO products for years and have been very pleased with them.

And by the way, if you ever need someone to demo your producy and give you feedback we are located in Shakopee, MN. (hint hint-wink wink).

LOL Have a good one, and keep up the good work!

JRCO
09-28-2009, 10:36 AM
Sorry, not to hijack the thread or anything here. I think it was Jim I talked to at Minnesota Maintenance Equipment's open house this morning, great guy and very informative We have been running your JRCO products for years and have been very pleased with them.

And by the way, if you ever need someone to demo your producy and give you feedback we are located in Shakopee, MN. (hint hint-wink wink).

LOL Have a good one, and keep up the good work!

Thanks for the kind words. Jim just gave me your card. I'll email you that aeration letter.

Bill