PDA

View Full Version : Grasshopper issues - please help


bass is good
09-27-2009, 08:13 AM
I have a Grasshopper 718 with 18 hp vanguard engine with about 2600 hours on it. Lately I have been having an issue with the engine periodically bogging down. It will run fine for a while, sometimes a day or 2 and then this starts. Sometimes it happens when the engine is cold, and sometimes when it is hot. Sometimes it lasts only a short period and sometimes it goes on all day, but then again it will start running fine again. Also, when this is occuring it will be more pronounced when I turn around, or go from reverse to forward - any change of direction - it will bog down and then come back up when I stop moving. Then this problem goes away and everything runs perfect. There is also some oil blowing into the air filter, this has been going on for a while. Not a whole lot where I have to constantly replace the filter, but it is blowing some oil in there. I don't see any active oil leaks anywhere on the engine. All gaskets and seals have been replaced at one time or another, the mower is almost 10 years old. There is no debris blocking the pin in the carbeurator. I have replaced the fuel filter, fuel lines, air filter and spark plugs. This is very frustrating due to the fact that there is no pattern or reason I can find for this to keep occuring. Any ideas? Thanks a lot.

bob
09-27-2009, 12:12 PM
My 725 Kubota was doing something simular. There is a single wire that goes to the coil. It was loose. The movement of the mower would interrupt current and the engine would slow down. Check your coil wires.