PDA

View Full Version : New guy, Z-Force 50 stops when taking off the brake


PlainsmanND
10-09-2009, 09:55 PM
Hello, I have a Z-Force 50 about 3 years old 275 hours. Its well maintained.

Today I went to get the last mow of the season in and when I take off the brake she stops. I suspect the seat switch, I unplugged and jumpered it but it acted the same way. Is there a diode in the switch where that isnít a valid test? Is there a way to disable that for certain so I can determine if itís the switch?

I am familiar with the mower and am pretty mechanical.

Procedurally, open the sticks, brake on, engine fires. Take in sticks and engine stops or take off brake engine stops.

Looks like a good technical group here so I expect someoneís seen this.

Mower serial 2G145Z00070

Thanks!

Restrorob
10-09-2009, 10:23 PM
Put a multimeter set on ohm's scale across the seat switch connectors (while un-plugged of course) then make a fist and push on the center of the seat, If the switch doesn't show a open and closed circuit while being pushed in and let out replace the switch.....

PlainsmanND
10-09-2009, 11:04 PM
Cool, so odds sound good its the seat switch. If thats the case where's the place to get one?

Thanks

Restrorob
10-10-2009, 10:51 AM
Any local or on-line MTD/Cub dealer;


http://www.upstateoutdoorpowerequipment.com
http://www.emerichsalesandservice.com
http://www.mmipowerequipment.com
http://www.riversedgecubcadet.com
http://www.bandfinc.com
http://www.suttontractor.com
http://www.worcesters.com
http://savillesequip.com
http://www.hbduvall.com
http://cortlandmow.com