PDA

View Full Version : exmark fuel/stall problem


Ziob
10-13-2009, 02:38 PM
hi,
we have another exmark that has been stalling randomly from time to time and couldn't figure out if it was a fuel problem or an electrical. as of late we put a larger fuel filter on it as our other one seemed to be running really low and the machine would stall...like it was running out of gas. Anyway the new filter keeps it running longer but the level still goes down low as you run it over time.... anyone know what coudl be causing not enough fuel flow to be getting to the filter and the filter fuel level to slowly go down until it is crying for gas?

main line has been replaced. does it on both tanks. any help appreciated would it be a bad fuel "pump" the pump on these isn't electrical but vaccuum. clogged tank maybe? its weird it will run low but when i come back in the morning after sitting fuell filter will be full again.

thanks!

Restrorob
10-13-2009, 09:38 PM
Check your gas caps and make sure both are venting properly....

Just for info, A fuel filter doesn't have to be full of fuel all the time and alot of them aren't.

Ziob
10-13-2009, 10:29 PM
yeah i know but this one starts out full and runs fine when there is gas in it but when the filter gets down low which takes a little while it'll start to stall out can get bad at times never happens when full though has to be a gas problem. usually filters are atlelast half full these will get down to almost nothing in them

GraZHopA
10-14-2009, 12:42 PM
I have had to replace the fuel pump on older mowers with Briggs motors. The first thing that I would do, if I were you, is check and make sure that you don't have any vacuum leak to the fuel pump. Then I would clean the tank(s). Does your tank(s) have a screen filter inside it? Then I would probably change the fuel pump. Just my $0.02, I hope it helps!

Ziob
10-14-2009, 08:03 PM
weird doesn't do it if mower deck isn't on.

Ziob
10-15-2009, 11:31 PM
putting new mechanical fuel pump on tomorrow hopefully that fixes it it has to be running out of gas fuel filter is almost empty its just gravity/pressure feeding from tank i think pump isn't working. if that isn't it i have no idea lines are new and tanks and splitters are flushed and clean there are no problems out to the fuel pump. when filter gets really low machines runs like crap and stalls but will run ok in the morning after the filter fills back up with gas a little