PDA

View Full Version : Hustler Super Z Coils


CJonesLawnTree
10-13-2009, 08:01 PM
this will probably make me look like an idiot, but a quick answer is worth it...what are the "coils" on the Kohler engine in a hustler super z? One member wrote these detiorate from heat over time and will go out eventually...is the coil that person's referring to the small, black module that the spark plug wire leads to?? If so, I know that's my problem, but would like a confirmation from someone who obviously knows more than me.
I've searched the parts list on the hustler manual, but cant seem to locate that item or what a coil is either.
THANKS!

Restrorob
10-13-2009, 09:16 PM
this will probably make me look like an idiot, but a quick answer is worth it...what are the "coils" on the Kohler engine in a hustler super z? One member wrote these detiorate from heat over time and will go out eventually...is the coil that person's referring to the small, black module that the spark plug wire leads to?? If so, I know that's my problem, but would like a confirmation from someone who obviously knows more than me.
I've searched the parts list on the hustler manual, but cant seem to locate that item or what a coil is either.
THANKS!


Yes, That's the coils.....

How do you "know" that's your problem ?

If engine model and spec numbers had been posted, I would have been posting a part number and link to a parts look-up site instead of this......

CJonesLawnTree
10-14-2009, 01:28 AM
IDK engine model, cant find #s to save my life...but I do know that I have the SuperZ Kohler 28hp EFI engine if that helps. Model of SuperZ is 928010 (memorized that when first purchased luckily). My problem sounds similar to another one posted about, but the guy didnt exactly ask a specific question, just "here's my problem, please explain."
When I remove one of the spark plug wires, the motor then of course fires on one cylinder...sounding exactly like the problem i have after it heats up after 1/2 day of mowing. Hasnt done this all season long, even on 98+ degree days mowing from dawn till dusk. But, it does have 1700+ hrs on it & im not sure if these have ever been replaced. After it sits about an hour and cools down, fires back up and mows for another good stretch, usually enough to let me almost finish my day (i dont like long lunches though!). When it first starts sputterin, its like its on 1cyl & then you can tell the fuel is flooding the engine (only 1cyl means 1/2 the spark/fire) & then kills it. I'm going to head to a shop in Lakeland (other local shop pissed me off last week) & inquire of their knowledge, then probably buy a coil...or two. On my model, the one coil is 3" from the exhaust & gets so hot I cant even touch. I would assume that's the one that went out.

CJonesLawnTree
10-14-2009, 01:29 AM
oh yeah...restrorob, thanks so much!!

CJonesLawnTree
10-14-2009, 07:59 AM
Kohler CV745 EFI, part # 788224 according to website parts manual.

CJonesLawnTree
10-14-2009, 06:46 PM
ok, according to local shop may be valves...the OHV cover is right next to exhaust & he says after getting so hot, valves are sticking...maybe one, or more. The coil was in stock, but $83 so i decided not worth the try if not the solution. Mowed all day today and was great, but no yard was bigger than 3/4acre. Even in one neighborhood where I had 4 together, I had to stop mower in between for rest of tasks (was by myself, gave employee off due to mower problems). Its only when its mowing ALL day non stop just about.

Restrorob
10-14-2009, 10:17 PM
i decided not worth the try if not the solution.


Ya Know...... You can test that coil with a multimeter set on ohms scale.


http://i107.photobucket.com/albums/m314/Restrorob/Kohler/CV/KohlerEFICoilTest.jpg

CJonesLawnTree
10-15-2009, 09:10 AM
awesome...how do you do that? I assume first I need to go buy a multi-meter? I had thought about testing voltage or sumthin coming from it...shop & decided when it "starts" problem symptoms again, I'll 1st remove plug wire near exhaust...if identical situation, re-install & then remove plug wire under seat on opposite side. If still no change & symptoms continue, then supposedly valves. If the mower does cut off abruptly when one plug or other is removed, that means engine was in fact running on just one cylinder, being one i unplugged & other left attached to spark plug isnt' working due to coil overheating. Guess an easy lil diagnostic but i have to wait for mower to mess up again, which may not be till next tuesday cuz our yards today, while 1-2 acres, dont seem to be enough to cause overheat on whatever part is doing it.

ricky86
10-15-2009, 08:35 PM
If you know what side is suspect, maybe try switching the coils from one side to the other. See if the problem changes sides. I have never seen one of those coils fail.

CJonesLawnTree
10-16-2009, 09:15 AM
Jeff, owner of Cutting Edge in Lakeland (biggest commercial shop in all of county) agrees with you. Says he's never seen a coil fail yet, even on a 2000hr+ unit. I mowed thurs all day w/ no problems. We have 2 yards at almost 2 acres, but since we're spread out even with helper mower gets time to cool/rest between yards (we only have a couple places on Thurs in which mow neighboring residents).
Thanks so much....I'm scared of this $500 valve job...i know its a repair beyond my scope.

ricky86
10-16-2009, 10:05 AM
Highly suspect of a sticking valve being the problem also.

CJonesLawnTree
11-05-2009, 08:40 AM
well, definitely now coils...had problem arise, so unplugged wire in rear near exhaust; continued running (barely). reattached & disconnected plug in rear; continued running (barely) also. Problem persisted & mower stayed on & "barely" running for nearly 2 solid minutes. I finally stopped it, then turned the key and got it start right back up, still exhibiting the identical running condition.
Guess that $500 kohler valve job is the problem? IDK if its ever been done on this mower, its got over 1700+ hrs so maybe just time for it. Gotta save in off season to pay that bill though.

AintNoFun
11-05-2009, 08:45 AM
i used to run a lot of hustlers with the kawi's when i cut grass.. it seemed like every year we were doing coils on 5 mowers when they got older....

RonAyersMotorsports
11-05-2009, 10:38 AM
Don't assume anything. Check compression on both cylinders first. Have you done a leak down test. Have you actually check for fire on the plugs when problems occurs? You haven't done any testing. Sounds like you may just need to take it to your dealer and let them figure things out.

Restrorob
11-05-2009, 01:12 PM
Sounds like you may just need to take it to your dealer and let them figure things out.


Ditto ^^^^^^ Especially with a EFI engine !

CJonesLawnTree
11-06-2009, 04:58 PM
originally meant "not" coils, not "now" coils. Yeah, dealer's goin to have to take it from here.