PDA

View Full Version : Tecumseh HM80 CARB HELP!


slowgsxr97
11-13-2009, 07:56 PM
Hello, all. looks like a great site.

I have a tecumseh hm80 on a snowblower, I completely rebuilt the carb, but it still wont run, I dont know how to describe it. The primer bulb gets rock hard, I mean it wont pump anything, almost like the carb is vapor locked, I can tap the carb it will let me get a half push in to prime and it will run for a second then dies with bulb getting rock hard again,

The carb is clean, new needle, seat, float, orings, gaskets.

PLease help me!

Restrorob
11-13-2009, 08:03 PM
Can you post the engine spec number ?

slowgsxr97
11-13-2009, 08:47 PM
The only numbers I can find on it are

143.00800

xtpxs.1631bf

Restrorob
11-14-2009, 07:27 AM
Hmmm,

The red flag went up when you posted HM80 and primmer bulb (I don't recall seeing this), That's why I asked for more numbers. With the Sears number you posted it shows a non-primmer bulb carb on this engine.

Did you just buy this unit ?

Has it ran in the past on this carb ?

Doe's this carb have three adjustment screws being one for idle speed, One below this one for low fuel mixture and one on the bottom of the float bowl for high speed mixture ?

Once I can Identify which carb you have we can see about problem areas that would keep it from running.

Even though the primmer isn't working properly the engine should still continue to run once cranked.

slowgsxr97
11-14-2009, 08:19 AM
The engine was manufactured in 95, It has NO adjustment screws at all, except for idle. its a 3.8hp. It is a vented primer bulb,

Im unsure of the last use of this blower. It had stuck floats when it was gave to me, gas poured out of the primer, other than that its all i know.

Restrorob
11-14-2009, 12:13 PM
OK,

A HM80 is a horizontal 8hp engine, The number you posted leads to a HM80.

Sooo, since it's a primmer carb there could be a spring loaded check valve behind the primmer bulb (which I couldn't confirm) that could be stuck. The float bowl retainer bolt is the main jet as well, Make sure all holes (two in the side and one in the center) in this bolt/jet are fully open.

slowgsxr97
11-14-2009, 02:30 PM
all 3 holes in the main jet are clean, I took it all apart again, I didnt even get a chance to pump it, soon as the gas filled the bowl primer was rock hard, there is no check valve on the primer, it functions as it should when un hooked.


still wont start

Restrorob
11-14-2009, 04:50 PM
There are three different primer style carbs;


http://i107.photobucket.com/albums/m314/Restrorob/Tecumseh/TecumsehPrimmerCarbs.jpg


The primer bulb pressurizes the fuel bowl which sends the fuel up through the emulsion tube into the throat of the carb.

Note the passage from the bulb area to the emulsion tube area on pic 4, This passage is right behind where the air filter base screw is inserted. If the air filter base screw has been lost and another longer screw installed this longer screw could restrict/close this passage and cause a hard non working primer bulb.

Also, If the screw is left out this passage being open will cause the primer not to function properly but won't cause it to be hard, It just won't pump enough fuel for start-up.

So, Make sure the emulsion tube is fully open and check the air filter base screw. The only thing left beside that would be this passage is plugged up, But their pretty large and I have never seen one completely blocked.

slowgsxr97
11-14-2009, 06:11 PM
my carb is number 3, you wouldnt happen to have a full diagram of that carb would you?

Restrorob
11-14-2009, 07:37 PM
Without proper model numbers I can only guess this one being close;


http://i107.photobucket.com/albums/m314/Restrorob/Tecumseh/TecuOHVCarbBreakdown.jpg


Part #20 is the low speed jet, There's a small pin hole in the tip that should be open. Also make sure o-rings #37 on the emulsion tube are good and sealing, Non sealing o-rings can hamper proper priming/running.

slowgsxr97
11-14-2009, 08:02 PM
im sorry, I meant the first picture, it was numbered 3....sorry

Restrorob
11-14-2009, 09:36 PM
Tell ya what, Since we have model number problems and I can't look up/see what you have sitting there in front of you here's a link;


http://toprake.com/index.php?module=documents&JAS_DocumentManager_op=list&MMN_position=11:11


Download the service manual and it will answer any questions you have, If not just shout back and I'll do the best I can.


Good Luck

slowgsxr97
11-15-2009, 08:32 PM
Tell ya what, Since we have model number problems and I can't look up/see what you have sitting there in front of you here's a link;


http://toprake.com/index.php?module=documents&JAS_DocumentManager_op=list&MMN_position=11:11


Download the service manual and it will answer any questions you have, If not just shout back and I'll do the best I can.


Good Luck

great link thanks for all your help, I think ill just roll this thing off the bridge,] :cry: