PDA

View Full Version : Wright 36' Pump belt keeps breakin!


wright5223
11-23-2009, 08:22 PM
Does anyone have a newer wright 36' stander that the pump belts keep slipping off then after a while it just breaks all together i've gone through about 3 belts this season just wondering if i'm the only one with this problem!

unkownfl
11-23-2009, 09:10 PM
Nope not here.

ed2hess
11-24-2009, 07:10 PM
Ours last one year but they are terrible to get on the sentar. Next time I am going to try turning the unit on its side. You need to get it up on a fork lift to see what might be going on.

WrightCommercial
11-25-2009, 12:04 PM
wright5223,

Your 36" was built with the lower tension idler setup so it shouldn't be a tension issue. Check the alignment of the pulleys in the drive system, without measuring you can look at the idler pulley to see where the belt has been running. If not near the center of the idler pulley you will want to check that the pump pulleys are level with the engine pulley (pump pulley should be around 1 7/16" from the bottom of the engine deck to the lower edge of the pump pulley). If they check out level but the idler pulley indicates an issue the idler can be adjusted by either removing or adding washers underneath the pulley. If everything appears level and running correctly the problem is either with the idler system or there could be a flaw in one of the pulley surfaces. With it slipping off, the idler is the most likely culprit, check that the pulley spins true with no bearing play and check the bearings in the pivot tube of the idler to make sure there is no wear spot that is not allowing the idler arm to move as it should.

Best Regards
Wright Mfg. Service Dept.

pugs
11-25-2009, 03:50 PM
Does anyone have a newer wright 36' stander that the pump belts keep slipping off then after a while it just breaks all together i've gone through about 3 belts this season just wondering if i'm the only one with this problem!

I didnt know they made 36 foot machines.