PDA

View Full Version : walker mower battery problems


lawnandl
04-15-2010, 03:50 PM
I have a 1995 walker mower model mtghs, with a 20hp kohler engine. The problem is that the battery keeps dying. Even if i replace the battery, 3 days or so go by and another dead battery. i've looked at the wiring and everything seems to be in tact. The battery dies when just sitting there not even turned on, like overnight. it's killing me to fix this myself and not drop it off and wait a week or two to get it back. any ideas? thanks......and time to go charge it again!...

Restrorob
04-15-2010, 06:40 PM
You could have two issues here but start with the no charge issue first which could solve the battery drain issue.

You have a three wire plug connector on the voltage regulator mounted to the flywheel cover, Use a automotive test light or multimeter and check for battery voltage on the center wire in this plug connector.

If you have battery voltage un-plug this connector, Now put the test leads from a multimeter set on AC volts across the two outer wires in this plug connector. Start the engine and give it full throttle, The reading should be anything above 28 volts AC.

If you get a reading of more than 28 volts AC replace the voltage regulator, Then start the engine and test across the battery post. It should read 13 to 14.5 DC volts.

If you now have the charging system functioning remove the positive battery cable and put your multimeter test leads between the cable and battery post, You should get no reading on the meter with everything off on the unit.

If you do get a reading you have a short in the electrical system, Start by checking the wire harness for any bare wires.

That should keep you busy for a little bit......

Good Luck

fixer67
04-15-2010, 08:30 PM
On a Walker there is a metal cover over the V/R. The back wheel fork can get bent letting the wheel hit the metal cover and pushing it into the V/R damaging the connector. I have seen dirt build up behind the cover and short the V/R as well. Remove the V/R and clean it. Check for damage to the casing. Clean the mouning holes as well. Make sure the V/R grounding strap is OK

lawnandl
04-24-2010, 04:53 PM
thanks for the input... there was no damage to the V/R. i took off the plate and checked the wires and they are fine. the three wire plug connector on the voltage regulator is also fine. What if the circuit breaker was bad or the relays, or safety switches? what would happen then?

fixer67
04-24-2010, 06:36 PM
There is no relay or safety switches on that circuit. Give me the model year and serial number and I will check about that breaker. With the key switch in the RUN position you should get 12 volts DC from the battery on the middle terminal and the frame at the V/R. With the engine running you should get any where from 28 to 36 volts AC from the two outer terminals at the V/R. Check and see what you at the V/R and let us know. Give me the model and year and serial number and I will get you some wiring info. I just thought of something. Check the starter. There is a purple wire at the starter on most models that runs to the V/R check the wire. Had one a few weeks back that a stick broke that wire and it stopped charging.

VegetiveSteam
04-26-2010, 11:03 AM
All of the previous posts have given you some great info but unless I've overlooked it in their posts they all forgot one very important thing to check that I see quite often. Make sure the voltage regualator is grounded. The two screws that mount the voltage regulator to the engine are different colors. Looking at the goldish colored one there is either a green wire or a thin strap on that screw. Make sure that is connected to ground. Another way to check if the regulator is properly grounded is to use your test light. If you do indeed have battery voltage to the center (violet) wire in the regulator plug with the key on proceed as follows. Connect your test light to the negative terminal of the battery. With the key turned on (engine doesn't need to be running) touch the metal case of the voltage regulator with your test light. Your light should NOT light. If it does then that tells you that the regulator is not grounded. Ground it and everything should work just fine.

lawnandl
04-26-2010, 03:10 PM
i did the test VegetiveSteam had said and the regulator is properly grounded. Is the circuit breaker supposed to light up with the test light on both posts when the key is off? because this is the case...also the starter wires are fine..i am now going to check test leads between the cable and battery post like restrorob suggested.

huntdeer
05-17-2010, 09:44 AM
what type battery does it take for a 16.5 diesel md? i recently purchased this mower and now it will not start. any suggestions would be greatly appreciated.

alanauer
06-01-2010, 11:24 AM
Sorry, hunt, don't know what an md is, but with a diesel, all the battery can do is spin it fast enough to ignite, and if that doesn't happen, it's usually a fuel problem.

Ruben Rocha
06-01-2010, 01:59 PM
Okay back to restrorob's suggestion did you check the voltage to see if it is charging at all.
What was the voltage?
If the voltage is correct for charging the battery and the battery is not defective.
Then his next suggestion was to check for a short.
Which means in the test the short is draining the battery.