PDA

View Full Version : echo PB1000 wont prime


kmacd
04-26-2010, 03:45 PM
I have an old blower. The prime bulb will not fill up with fuel. I bought a new carb but it did not come with a pribe bulb on it, it had a plate where the prime bulb goes. I put the old prime bulb on the new carb and I have the same issue. I replaced the fuel lines but not the filter at the end of the fuel line.

Do you know if this filter is suppose to be a filter/check valve? As I press/depress the prime bulb I can see fuel going up the tube but then back down. It almost seems like it needs a check valve to keep the fuel from going back in the tank. The fuel never fills the bulb. Any suggestions would be appreciated.

hydrosmurf
04-26-2010, 04:00 PM
If it is like some of my other Echo equipment, the check valve for the primer is in the primer bulb base. Once when I had a similar problem I pushed the primer bulb in, then pinched the fuel return hose closed while the bulb expanded to its original shape. This kept the primer bulb sucking fuel from the tank and into the carb, rather than sucking air from the return fuel like.

It was one of those things that once fuel reached the primer bulb, the check valves started to work properly again. Hope you have similar luck.

topsites
04-27-2010, 01:35 AM
Either that or you need a new bulb, dealers do sell these.
Yes, the bulb itself, easy to replace, nice new plastic all see through, run ya a few dollars for several.

coyote247
04-27-2010, 07:13 PM
Exactly, check your bulb good. I have had a few that had either cracked or developed a tiny hole in them, which makes them useless.

dutch1
04-27-2010, 07:55 PM
There are actually two check valves in the primer base--one that lets the fuel enter the primer bulb chamber from the vacuum created when the primer bulb is released. When the primer bulb is pressed the check valve that permits fuel to enter closes and the check valve to the return line opens. Keep in mind that the primer bulb actually pulls fuel through the carb to the primer bulb then when the primer bulb has filled, the fuel in the primer bultb is returned the tank by the return line upon more primer activation.

I wouldn't think that this is your problem since you say the carb is new and came with a new primer base.

If your bulb is OK, you may want to check to see if you may have the two fuel lines to the carb reversed. If the lines are reversed the fuel you see coming up a line could be the result of air you are introducing to the tank by the priming process.

kmacd
04-27-2010, 09:13 PM
I think I need to order A primer base/primer bulb. I ordered a new carb based on my serial number. I went to partstree and looked up my part number. When the carb came it did not have a primer base/bulb, it had a blank plate over where the primer base goes. i was very frustraited this was the whole reason I bought a whole new carb.

I have a clear gas tube going to the carb, when the bulb depresses It sucks fuel up the line just about to the carb, when I pres the bulb again the fuel leaves the tube back in the tank. It seems like it needs a check valve that wont let the pressure force the fuel back to the tank.

Thanks for your help