PDA

View Full Version : 1994 Walker MT Kohler 20 Spec:64554 - Idle problems


tyler_mott85
04-27-2010, 01:11 AM
Hey all. We're testing the above mower out this week to see if we want to purchase it. Just picked it up from the dealer today and already having problems.

First a little bit more history about the mower.

The mower is a 1994 but only has 1200 hrs. Body is in fair shape and the entire mower looks respectable for that many years.

Started right up at the dealer hadn't been started since Saturday when we looked at it. Put it on the trailer drove it about 15 minutes. Started right back up. Drove it around to check the hydros after they warmed up, everything was running well.
Lowered the throttle to minimum idle and the idle became very rough, inconsistent, almost wanting to die.
Bumped up the throttle and the mower hesitated and after a puff of black smoke revved up to where it needed to be. The higher the RPMs the better the motor ran.

Shut it off for the afternoon and about 5 hours later tonight we started it again. Started right up with no choke. Drove it for about 5 minutes. Lowered the idle all the way back and shut the mower off to check tire pressure, etc before using it tomorrow.

Went to start it back up and it would crank but no fire. Walked away for 5 minutes, nothing. Ended up unscrewing the airfilter on the top of the motor and spraying carb cleaner into the carb. Mower started. Struggled, but started. Ran well, lowered to idle again to just let it idle to see if it would die and within 30 seconds it did die. Went to start again, same problem. No firing, whether throttle was full or idle or choke was on or off or any combination in between. After having to charge the battery had to spray carb cleaner again to get it started. Shut it off at half throttle and it started right back up.

Any suggestions as to whats causing the rough idle/no fire problem? The Airfilter on the snorkel was junk, completely filthy. New filter, no change except you could tell a difference when we took the old off the mower ran better.

We didn't check plugs to see how they looked since it was dark out, We're thinking its a spark problem that the mower is flooding itself out at lower idle.

Thanks for any help!

ericg
04-27-2010, 07:24 AM
Your carb is in need of a good cleaning. Black smoke is evidence of a rich condition. Having to use carb cleaner is another indication that the idle circuit of the carb is partially clogged. The dirty air cleaner did not help the situation. Either take the carb off and rebuild it or purchase a new carb. Either way, you will be fine. This is not a spark issue.

Eric