PDA

View Full Version : oil pressure gauge low


rodney
07-06-2002, 10:42 PM
my 93 ford f-150 has a brand new mustang 302 in it .around 2000 miles. and the oil gauge reads normal with gas and low with out gas .when its low its where the neddle goes when its not running .
i dont no what to do its not making any funny sounds and has plenty of power. some one please help ! alsowhile running the neddle always stayed in the middle and didnt move . now it moves from low to normal if you give it gas and then back to low if you let off the gas , low is in the red .

MATTHEW
07-08-2002, 10:06 PM
When it didn't move, the pressure sensor was probably gummed up. It should move like it is, going up whe you accelerate.

As far as the needle point, you'll never know unless you get a compression test. Go t a service station and get one. Then, you'll know for sure if the guage is just "off".

75
07-09-2002, 06:12 PM
I presume the current (stock) oil pressure gauge is electric, I would suggest first putting a good mechanical (direct reading, the kind with an oil line that runs right into the gauge) on and seeing what it reads. It doesn't have to be a permanent installation, you simply want to see what the oil pressure really is.

My experience is with small block Chevys as opposed to Fords, but idle oil pressure is generally fairly low to begin with.

Give the mechanical gauge a try and see what it tells you, it's possible either gauge itself or the sender (maybe even both) are acting up.

Bill Kapaun
07-14-2002, 11:18 PM
It's my understanding that at least some of the Fords of this era don't have a gauge like we would expect. They take the approach that oil pressure, temperature etc. is "normal" or it isn't.
The only way to find out what your "real" OP is by connecting a mechanical gauge as previously suggested. This can be just temporary so you can compare the readings to each other.

A thought that just occured to me is this:
You state you just installed a "brand new Mustang engine". What was the original engine. It may have higher oil pressure specs than the "Mustang" engine and a gauge that is calibrated to the factory engine. A difference of 5 PSI lower at idle for the "Mustang" engine may be totally within specs for that engine, but the gauge believes it to be way too low for the engine it is calibrated for.
I would look in some repair manuals first and see what the oil pressure specs are for the 2 different engines.
Another thought. Is the sending unit the proper one for that gauge, or the one that came with the "Mustang" engine. Sending units could very possibly have different calibration curves.