PDA

View Full Version : problem with walker cutting off


fenceguy81
05-07-2010, 10:23 PM
i have a walker mower that will just sut off. for some reason the battery keeps goin dead. i had it checked and supposly its good. i can jump the mower off and it will run for about 5 min some times less, and then just cut off. usually i can jump it back off and it will run for a bit and die again. but today it ran for about 5 min and died and now it wont start. it wont even turn the starter over. i hooked the jumper cables to it and it wont do anything. with the cables hooked up i can make the starter spin using a screwdriver to jump the selenoid. but when i turn the key with the cables hooked up it does nothing. anyone got an idea?

bob
05-07-2010, 10:25 PM
It might be the voltage regulator.

fenceguy81
05-07-2010, 11:51 PM
i did notice that when it was running that the fuel filter was full, but after it cut off i noticed it had very little in it. is this normal or could there be a problem causing there to not be enuff getting to filter. just got this mower and it cuts great but i cant figure out why it keeps cutting off. it ran fine two weeks ago. could the battery be a prob?

fixer67
05-08-2010, 12:26 AM
First off I hope this is NOT an EFI you are jumping off. Get it started and look at eh volt meter on the panel. It should read about 14 volts or a bit higher just after starting and drop to about 13 or so. Do the test and tell us what you get.

fenceguy81
05-08-2010, 11:52 AM
i checked all the wires going to the battery and even checked all the wires behind the switch panel. all look good and are clean. but i still cant get it to turn over using the key. when i turn the key it acts like there is no power. but if i hook the jump cables to it i can make the starter spin using a screw driver but it wont spark to start. anybody got any ideas? dont really want to take this to the dealer. bought this thing used but it ran great. it was running great a week ago. will a bad battery have any afffect on it. i had it checked and was told it was good but it keeps going dead even if i leave the positive cable unhooked. really need to figure it out and get it back mowing.

fenceguy81
05-08-2010, 12:41 PM
not sure what year it is but it is a mt model with a 25 horse kholer engine if this helps

starry night
05-08-2010, 01:00 PM
Do you have a nearby Walker dealer?

fenceguy81
05-08-2010, 01:48 PM
yes there is one about 20 from here. if i cant figure it out myself i reckon i will have to take it to them. i was hoping that i could fix it myself to save a lil money.

Impressions Landscaping
05-08-2010, 07:03 PM
Start checking safety switches, all fuses, and relays. Check for loose grounds all over the mower. Mine did the same thing, ended up being a bad safety switch on the blade handle.