PDA

View Full Version : BR600 Problem


010752
05-09-2010, 10:15 PM
Hi, new to the forum, but have been happily using Stihl stuff for about 30 years, mostly chainsaws.

Bought a new br600 a few years ago, figured even though it was a new design engine, Stihl would have it figured out, after reading thru a bunch of posts here, I guess they didn't.

Run about 2 days a week, always used Stihl oil and fresh gas. Problems started when Florida went to E10 gas. First the oring on the gas gap would swell and after figuring that out replacing orings every few months cured that issue. Next the fuel lines deteriorated and leaked.

Lately, it started properly, ran well for the first few minutes but never was able to hold full throttle, although the accelerater pump seemed to help the rpms.

Air filter clean, valve adjustment good, cam timing right, good fuel flow to carb, good spark. Good compression, hot or cold.
Fuel pickup never has been a problem for this one.

Over the few years there seems to be a bit of oil seepage residue at the bottom of the engine, not sure if it;s a crank seal, but looks like it probably is.
Presently, the gas tank gets pressurized even when just trying too start it, don't know if that is normal.
Doesn't seem to be getting fuel thru the carb to the cylinder.

I'm guessing the next step is to get a new carb.
Don't know whether it is worth trying, am sort of dissappointed with this whole piece. Is the new style retrofit carb worth it and if so how much are they.
This also has the broken backstrap mount.
Also use another 4mix, an FS 110R, using the same fuel and only had the gas cap oring problem.
The dealers around here are sort of clueless, they havent even heard of the Magnums.
I just don't want to end up beating a dead horse. Maybe getting the biggest Stihl 2 stoke is a better fix.:hammerhead:

Any help would be appreciated.:usflag:

Jay Ray
05-09-2010, 10:37 PM
As a last resort when all else fails, cook the muffler.

Let it soak in paint thinner or acetone (or both) overnight. Then shake out all of it you can. Then heat the muffler with a torch until it is all boiled and burned out. A propane torch will do; don't want too much heat too fast.

Be very careful. Face shield advised.

Also clean the exhaust port.

Incoming:laugh::laugh::laugh:

010752
05-09-2010, 11:01 PM
Thanks.

Forgot to mention that, The muffler and screen are clear.

rotti1968
05-10-2010, 08:01 AM
I have seen the oil seals seep on these units quite often. As far as throttle loss goes there a few things that may cause this on the older br 600's . 1: carburetor internal leaks,leaking covers and gaskets,worn throttle shaft and carb body,bad/leaking accelerator pump.2: bad ignition module , the rev limiter/governor part of the board goes bad and does not let the unit come up to full speed.3: cam gear the lobe is worn, or the acr is not working. 4:leaking valve cover gasket (install new gasket and sealing ring after valve adjustment) and valves not adjusted properly.5:excessive carbon build up on valves and top of piston and cylinder.6: worn valve guides and or valves and seats,worn rings,stuck rings .7: air leaks . The 500,550 and 600 blowers have had issues since they first came out as has been discussed on this board many times over. I can honestly say that since the new magnums have come out I have not had one come through the shop with the exception of the first few they produced that did not have the dual fuel pick up installed, and we put the 2nd pickup in them.
I would pressure and vacuum test this unit for air leaks , then do a leak down test on it . If you get anymore then 10% leak down this unit will not run correctly.