PDA

View Full Version : LandPride left side doesn't seem to have the same power as right


watson524
05-10-2010, 03:16 PM
Hi all,

I am running my dad's LandPride 60" ZTR. There's a pretty steep hill in my parent's yard and even on smaller hills, I feel like the left side is lacking power. It'll creep up and if I'm all the way forward on both sides, it goes to the left because the right side seems to have more power.

There's no leaks anywhere so I don't believe it's a fluid issue and on the level, all tracks ok and neutral sits still. I thought perhaps I needed to shorten up the rod a bit on the left side so full forward is opening the pump more. I loosened the stop nut on the backside and tried to put pliers on the flat part of the bar and turn counterclockwise/inward and it wouldn't move. Also tried outward. There's what looks like a stop nut up front too right at the end of the threads under the black piece that I can't get loose (even after liquid wrench) but the book didn't say I should have to do anything with that so I was hoping you could help. The other thought is that I have a weak hydro pump on the left side (it's a 2001 or 2002 mower). If it's a weak pump, is that something fairly easy to replace myself? I'm pretty handy with a wrench... And do you know about what those run?

thanks in advance!

watson524
05-11-2010, 05:31 PM
bump. hoping to get some help on this.

thanks!

cowetamike
08-24-2010, 11:24 AM
it is possible that you need to adjust the tension on the hydro drive belt it may be stretched and the way it is routed around the pullies it may loose a little tension. Adjust the belt and see if that helps

BigFish
08-24-2010, 02:02 PM
it is possible that you need to adjust the tension on the hydro drive belt it may be stretched and the way it is routed around the pullies it may loose a little tension. Adjust the belt and see if that helps

Read the post date!! Back in May! It's a good bet he figured it out by now, ya think?