PDA

View Full Version : kohler runs rough at full throttle


ealbertson
05-17-2010, 05:11 PM
I have a 60" eXmark TTHP with a Kohler 23 hp engine on it. The engine specs are: Kohler 23hp CV23S Spec: 75559 S.N.: 3225503391. The symptoms are every time hot or cold, when I go to full throttle it runs rough like it is missing. I have noticed a little black smoke on occasion while it is doing this. One plug I forget which side is blacker than the other. I can just a consistently clear it up by throttling down and then quickly back up. After this it runs smooth until I slow it down or restart it. It also, most of the time, back fires when I shut it off. It will do this even when I let it sit at idle for ten or more seconds although it is worse when I throttle down quickly and shut it off. Once in a great while it starts hard needing choking and this is usually when it is warm. I have had the carb all the way apart and cleaned it thoroughly not to long ago. Also, I replaced the carb diaphragm for a different problem last year.

Any thoughts will be appreciated.

MileHigh
05-17-2010, 05:16 PM
kohlers are all custom...LOL!...ya know what i mean, at least you can clear it up.

mine will backfire when it shuts off unless you turn it off at a certain rpm near the middle of the spectrum.

Glenn Lawn Care
05-17-2010, 05:55 PM
maybe fuel filter is clogged

mbrew
05-17-2010, 09:32 PM
I don't know how the linkage is aranged on that motor, but it sounds like the choke is coming on. The black smoke would back that up and also would eliminate the fuel filter. Whether the choke is coming on at full throttle or not, the smoke indicates a rich condition.

Mike

jrush
05-17-2010, 09:45 PM
My Kohler was doing the same, the dealer said it was the carb and it needed to be taken apart...I didn't have the time so I said I would bring it back well, I got home after mowing all day and still had some energy so I was going to take a look at it. I went to clean the carb only to notice the two 10mm nuts that hold it on where missing, so the space in between the engine and carb was not only sucking in to much air but all the crap that got kicked up while mowing. Two weeks later the damn engine blew and they wouldn't cover it under warranty. (2 months out with 430 hrs)