PDA

View Full Version : Demo'd today....


biggziff
05-17-2010, 09:36 PM
One of the local dealers brought me a shiny new Ferris IS1500Z to try out today. 21HP Kawi and 48" deck. 2009 model without the ICD deck. My grass was high and damp so of course I tried to mow wide open. Once I got past the drunken sailor mode of driving (first time on a ZTR) the mower seemed to do a pretty good job. Mowed a bit on one of my small sidehills and it looked OK other than the dandelion stems sticking up where I mowed. Mower had plenty of power and was easy to control. It also fit in my garage in the spot where my JD LX277 used to live. After an hour or so the dealer leaves with the mower and go about my business. A few hours later I'm wandering around the front yard and see that the cut wasn't really all that great. On the side hill (gradual hill...not steep) there were low spots from the downhill side of the deck and some areas on the level spots where there were "ridges" of higher grass maybe 2-3" wide. To be fair, I was trying to load the engine by mowing really fast in high grass so is what I'm describing normal? I don't know if the deck was level, what the tire pressures were or anything..they brought it and I mowed with it.

The Ferris seemed to be built pretty nice. I did like the 28HP 61" ICD deck model I looked at later on a bit better though. That extra size on the deck really looked nice and seemed like it would make trimming a lot easier too.

Any thoughts?

thanks

Lawnut101
05-17-2010, 11:52 PM
Post some pictures. Then we can see what you are talking about

sharpcuts
05-18-2010, 12:10 AM
No mower does a great job in the conditions you described. As far as the lean on the slope. I used to sell ferris & we had complaints from commercial guys about this. they claimed that the suspension frame allowed it to lean on a slope. I can't say they do or don't, never tried it, only heard of it. There are others on here with ferris mowers, they probably could tell you if that's true or not.

biggziff
05-18-2010, 08:08 AM
Thanks for the replies. I mowed it all again with my LX277 which always leaves a perfect cut so I can't take photos of the issue now.