PDA

View Full Version : Fastrak Honda GXV610 engine surges when hot


PaBobW
06-21-2010, 09:07 PM
I bought a Fastrak with the Honda engine option. The unit had sat for a long time prior to sale, and the carburetor was recently replaced under warranty with a new unit due to an inability to idle smoothly. The mower now starts fine, and idles fine when cool. It runs like a champ, however when I idle down after mowing, it then surges significantly - almost cutting off and then sputtering back up. This is similar behavior to what it was doing before the carb replacement, and it only acts up when warm - after mowing. I am wondering if the fuel line inside the engine cover is getting too warm/hot and causing the issue. I plan to contact my dealer, but figured I would query the experts on this forum to see if anyone had any ideas.

Anyone experience similar issues with the GXV610 engine? Otherwise, the mower is tremendous.

PJ - I am in Pennsylvania - close to Everett. My local dealer who performed the work is Hines Equipment - great guys, excellent work.

mowerconsultant
06-22-2010, 11:42 AM
I havent heard of this problem, let us know what your dealer has to say.

Pj

Specop_007
06-24-2010, 02:00 PM
I have a Honda GXV530 that surges when its cold. Once its warmed up though it just purrs along. Curious what your dealer says though.

PaBobW
07-03-2010, 05:34 PM
Got it back from the dealer today - no change. The looked at it, but there is very little adjustment (according to them) on the Honda carb, and apparently they just run super lean. Under load while mowing, the thing is stellar, but if you stop the blades, and idle down for a moment - perhaps to get the mail out of the box, the darn thing will barely run. It's a shame, but apparently that is the way the Honda's are. I expected the Honda to be the best of the engine options, but now I am wondering if I made the right choice. I can't imagine Honda created an engine with this to be the intended performance, but as it has a brand new carb installed on it, and overall less than 30 hours, I have to put my trust in the guys at my dealer. If anyone finds a solution/fix, please let me know.