PDA

View Full Version : Problem with Suzuki 2-cycle engine


gewald
06-23-2010, 09:28 AM
Picked up an old 22041 push mower (contractor model) with a Suzuki 2-cycle engine. Hadn't been run in a while so the fuel line had turned to mush. Replaced the fuel line and filter and the primer bulb and I have tried to clean the carb but I still can't get it to run. Engine starts with gas poured into spark plug opening. I replaced the three gaskets closest to the engine. Cleaned off the needle, but I think the jet valve might be the next thing to tackle. Will try soaking it in carb cleaner. Haven't figured out exactly the flow of fuel through the carb yet.

The Toro Company
06-23-2010, 11:03 AM
gewald -

The best bet to help you trouble shoot the issue(s) is to refer to the Suzuki engine service manual. You can order this through your local Toro dealer. The Toro part # the dealer will need to order is 492-0260. Good luck.

-The Toro Company

gewald
06-23-2010, 02:10 PM
Though it doesn't offer much help other than to "clean the carb parts in carb cleaner". Should I consider replacing the jet and/or needle. To my untrained eye the needle looks fine. I can't tell if the center column (that the jet is screwed into) is clear, or should be. Is that how fuel enters the carb chamber to enter the engine? If I blow carb cleaner into the fuel inlet where should I expect it to come out? The flaps move freely. The primer seems to be working. The needle had a greenish powder on it that almost looked like mold, but I cleaned it and put it back in.

The Toro Company
06-24-2010, 05:15 PM
gewald -

By your description, replacing the jet and needle and seat would seem to be a logical next step. However, we cannot say definitively if this will solve your problems. Ultimately it has to be your call.

-The Toro Company