PDA

View Full Version : elec. woes....


BULLDOG
03-07-2000, 03:02 AM
1992 C-1500 silverado, 5.7 engine<br>i have an intermittit problem w/ the rear tail lites. the head lites work fine,but the rear won't.. turn signals,flashers etc.....<br>bulbs r good.... wires seem fine.....<br>it has a circuit board tail lite assym.<br>any help would b deeply appreciated !!!<br>&quot;BULLDOG&quot;

haulinbass
03-07-2000, 05:32 PM
bulldog,<br>check out 89 chevy 3500 discussion. should solve your problem. me and a buddy have the same rig and had the same problem at the exact same time. were going nuts trying to figure it out....h-bass

yortengel
03-12-2000, 12:28 PM
I know that there are a lot of problem with the circuit boards that the lights plug into. I have replaced many over the years, I have found it easyer than trying to fix them. Good Luck

CA Enterprises
03-14-2000, 06:00 AM
Hey,<p>What do ya know, is this just a common problem or what?<p>I had a similar problem with 96 C1500. Except that the rear brake lights wouldn't light. The third over the Cab worked fine, everything else turn signal etc. worked fine. Tried bulbs, wireing, brake switch, and finally thought it was the &quot;multi-function&quot; switch in steering column. That switch is about $300. And with the p/u having an airbag I decided to give it to the dealer. <p>The dealer called after 6 hours and said it was ready and the total was $55?! What it was, there happens to be buss bar under the hood. This bar has fuses!!!!! Though the wireing diagram doesn't show it. <p>Anyway, hope you find it, I doubt that would be your problem, but sounds like Chevy has some common problem in the rear tail assembly.<p>Adam :)

plowking35
03-14-2000, 08:53 PM
Same under hood fuse problem with my 98 k-3500 cab chassis.<br>Mine was still under warranty tho.<br>Dino