PDA

View Full Version : Torro Timecutter Z mower won't start.


JSLawnman
08-07-2010, 06:16 PM
Hi. I've been meaning to register and join in with you all for a while. I am finally here today with problems.

I bought my mower two months ago from Home Depot and it is still under warranty, but they are telling me it's going to be two weeks or more for turn around.

I just want to see if any has any ideas for me.

I got home from mowing today, rode it off the trailor, went to do something, came back and it would not start.
When I turn it, it does not even click. There is plenty of gas, checked everything I can think of and everything looks great.
Any ideas would be great!

adrianrog
08-07-2010, 09:32 PM
Sounds like a safety switch somewhere. If it's not even turning over, are you sitting on it, are the blades disengaged, and are the handlebars pushed out into the neutral position?

Just curious, what kind of engine?

JSLawnman
08-07-2010, 09:42 PM
I am sitting on, blades are disingaged. It is a 24 hp kawasaki engine. Possibly blades were engaged at low throttle?

adrianrog
08-07-2010, 10:09 PM
I wouldn't think engaging the blades at low throttle would make it not start, even if engaging them killed the engine.

I'm not a mechanic and don't know anything about that model, but if it's not doing anything at all, I think it has to be the battery is dead or a safety switch. A safety switch seems likely at this point. Sorry I can't be of more help, maybe someone else on here knows common problems.

topsites
08-07-2010, 10:41 PM
Check the fuse(s)

newz7151
08-08-2010, 12:47 AM
check to make sure the safety switches on the arm "park" position did not pop out of their snap in slots. (you can pop the rectangular cover off on the front of the arm gear box)

ricky86
08-08-2010, 08:10 PM
Check the battery first. Or try jump starting off a vehicle. Make sure NOT to have the vehicle running, and to hook the cables up correctly the first time.

adrianrog
08-08-2010, 10:19 PM
My neighbor bought one of these today with a 24HP Kaw, hope it does well for him. If you figure out what the problem is, post the fix and I'll file it away in my brain in case he has a similar issue.

-Adrian