PDA

View Full Version : Kohler CH25 Miss And Rough Running


digger23
08-08-2010, 03:51 PM
Hi,

My Kohler CH25 suddenly started dying at idle and running rough with an occasional backfire.

I suspected a head gasket, so I bought an inexpensive leakdown tester from HF. Both cylinders show the same thing, 50% leakage (moderate, according to the scale), hot or cold. Both plugs look fine, and an inline spark tester shows a good spark on both cylinders. There are no unusual mechanical noises.

Stone cold, the engine starts and idles fine. After a couple of minutes at most, it starts missing and will die unless the throttle is advanced. At full throttle it can still do useful work, but doesn't put out full power.

If I pull the plug wires in turn, the engine runs the same on either plug.

The engine has less than 100 hours. The fuel is fresh. The oil and air cleaner were just changed.

The one thing I noticed that seemed a bit odd was spurts of fuel from a horizontal brass tube in the carb throat. It sticks out from the front side of the bore. My service manual's exploded parts view does not show that tube, so I'm not sure exactly what it is. I assume it is the main jet, but it doesn't spray. It shoots a stream of fuel that seems a bit irregular.

Thoughts?

Restrorob
08-08-2010, 08:44 PM
I have some thoughts but I need the spec number off the engine; http://www.lawnsite.com/showthread.php?t=144040

digger23
08-08-2010, 09:38 PM
I have some thoughts but I need the spec number off the engine;

CH730-0038.

I've been reading up on carbs this evening. I believe that tube is the emulsion tube, and the gas is not being emulsified properly. I think I may have a blocked air passage in the carb. Absent a more compelling suggestion from someone here, I will tear the carb apart tomorrow.

Restrorob
08-09-2010, 10:40 AM
That brass tube is the outlet for the accelerator pump, It shouldn't display any fuel spray/drops until the throttle is moved from idle to higher speeds.

If you are seeing fuel from this tube at any given steady throttle position there is a crack/pin hole in this accelerator pump diaphragm, You will need part # 24 757 08-S diaphragm kit to solve the issue.

digger23
08-09-2010, 04:41 PM
Thank you for the part number, but the tube I am referring to isn't the accelerator pump. On my carb, the accelerator pump tube is to the rear, while the tube of interest is on the front (blower shroud) side of the throat.

I am certain it is the emulsion tube for the main jet, even though I can't find any parts breakdown that says exactly that. The air port(s) for the tube were clogged. I managed to blow whatever was in there out with compressed air. The machine is running normally now.

Thanks again.