PDA

View Full Version : JD 425 strange starter problem


Dimark1009
09-07-2010, 07:35 AM
OK, I need help from the more knowledgeable again...

I am working on a John Deere 425 All Wheel Steer tractor with Kawasaki FD420D engine.

I originally got the tractor in because the oil pump gear broke. I rebuilt the engine and sat it back in place.

now the problem,

Sometimes when I turn the key, the starter cranks with the key in the ON position. I did replace the circuit board/keyswitch thinking it was related to that.

It doesnt do it all the time, sometimes it starts and runs fine. other times it will crank as soon as the key is in the ON position.

I tried different batteries, checked the wires, all seems OK.

when I took the engine out I only had to unplug 2 wire harnesses, they cant be reversed.

anyone know what to look for??

thanks,

Mark

Restrorob
09-07-2010, 09:17 PM
Mark,


Take a look at the battery cable on the starter, Make sure it didn't twist when you tightened it causing it to touch any other post on the solenoid.

Yeah I know, Doesn't make sense....

I faintly remember a situation such as this after a starter replacement and that's what I found.

Dimark1009
09-08-2010, 06:05 AM
I will check that Restro-thanks.


here's something weird I did see last night working on it. for a while it was doing this "crank in key ON" thing,

I noticed this...

you dont have to have the brake on for this to occur

you dont have to be on the seat for this to occur

no lights light up on the circuit board.

I tapped on the circuit board last night and then put a battery charger on the battery (it was slightly low)

after a few minutes it started fine, i ran it for 15 minutes.

does this make any sense??