PDA

View Full Version : 95 Turf tracer intermittant misfire hot ? kohler


turf&snow98
09-21-2010, 09:08 PM
I really need help. I have a 95 turf tracer with a kohler command pro gas engine. It runs great for about 20 minutes cutting, then will all of a sudden start to misfire, it will gradually slow the engine down and usually will just shut off unless i shut the deck off and get it to the trailer quick. Here is what i have done so far, new battery, new stator, new stator regulator, new flywheel, 2 new coils, 2 new plugs, new ignition switch, all kohler and exmark parts. I have good fuel and cold compression. Seems like it might be heat related possibly ?? Usally after it sits for a day or two it fires up, runs perfect for 20 min, then repeats the problem. Sometimes though, even if i shut it off and don't use it for a few days when i go to start it, it miss fires. Any suggestions ? *trucewhiteflag*

Restrorob
09-21-2010, 10:01 PM
How about a engine model and spec number ?

Any signs of a oil leak anywhere ?

piston slapper
09-22-2010, 10:11 AM
I'm guessing you have a 22 or 25 hp engine. (smart spark w SAM module)
Did you get the SAM module checked ? ( Kohler SAM sequencer about $300)
Are the coils gapped at .013 ?
Do you have a good ground to the white wire that bolts to the intake ?
Do all the connections to the coils fit snugly?

Replacing parts is the expensive way to diagnose an engine.

turf&snow98
10-05-2010, 07:52 PM
Sorry i was slow to respond. It is a CV22s spec-67516
I have no idea how to check the SAM moudle.
The coils are gapped correctly.
Grounds are good, new eyelets and epoxy sealed.
The flywheel & stator were replaced because most of the magnets fell off . The coils were both replaced because the wires were arching to the block occosionally (which i though was the problem.)
Thanks in advance for the help.

turf&snow98
10-08-2010, 10:34 PM
I was out mowing today i think the sam module may be an accurate guess.