PDA

View Full Version : Lawn Solutions ride on fluids


grassmasterswilson
10-03-2010, 07:07 AM
Picked up my LS ride on Friday afternoon. It came without the owner's manual, which I called and got them to mail to me.

My Hydro resevior is bone dry, but I see fluid in the eye glass. I want to add some to the resivior .... at least to the cold line. What oil is recommended for this?

djagusch
10-03-2010, 11:19 AM
I would like to know why it was bone dry? Did they have a sticker or warning tags to fill it before use? Running the hydro's low for a short period is not good for them. LS has a great product but needs to get the production side down. The 24" W/B is way late and you here many without manuals etc. Doing it right the first time would make their life alot easier.

lush&green
10-03-2010, 12:19 PM
Mine is as well and I did not get a manual.?? Once we get this thing back from the repair shop I will fill it if needed..

grassmasterswilson
10-03-2010, 01:44 PM
It has oil up by the pump and I can see it in the sight glass up under the controls. The plastic resivoir by the motor is what is empty. the cold line is not very high up, but am assuming that it should be filled to the cold line and then might expand as the oil heats up.

What kind of oil do you use for the hydro pump?

Service 1st Lawn Care
10-03-2010, 03:14 PM
Mine is as well and I did not get a manual.?? Once we get this thing back from the repair shop I will fill it if needed..

Just wondering why the unit is in the shop and how soon after you bought it it had to go to the shop?

Service 1st Lawn Care
10-03-2010, 03:20 PM
Mine is as well and I did not get a manual.?? Once we get this thing back from the repair shop I will fill it if needed..

How do you like the Aerator

lush&green
10-03-2010, 05:42 PM
Don't know? It came friday and it appears the starter is shot and we blew a tire getting it off the **** pallet...I am hoping to use it this week...

grassmasterswilson
10-03-2010, 06:03 PM
Don't know? It came friday and it appears the starter is shot and we blew a tire getting it off the **** pallet...I am hoping to use it this week...

Don't know about yours, but my crate was pretty weak. Had mine delivered to my chemical company cause I don't have a fork lift. We didn't even feel comfortable loading it on my trailer for fear the pallet would fall apart. I un crated it and drove it on the trailer.

indyturf
10-03-2010, 09:08 PM
Probably has no fluids because of shipping? I have shipped equipment before and had to drain all fluids.

grassmasterswilson
10-03-2010, 09:22 PM
Got a ton of fescue renovations to do starting first thing in the morning. Can anyone tell me what the recommended type of oil is for the hydro pump??? Think my ztr's use synthetic 10w-30.

CHARLES CUE
10-03-2010, 09:47 PM
Man sorry no one can answer your question went to lawnsolutions web site they have manuals but could not get them to down load.

I would go with a 5w20 oil but i dont think i would go with synthetic some time you cant mix synthetics. Good luck with your adventure seems like they dont have to much support. and shipping is a ***** no one that handles your stuff gives a rats a??. They bash and bang and smash and only liable for the first $100.

Charles Cue

MnLefty
10-03-2010, 11:09 PM
Got a ton of fescue renovations to do starting first thing in the morning. Can anyone tell me what the recommended type of oil is for the hydro pump??? Think my ztr's use synthetic 10w-30.

I'll let you know first thing in the morning, my manual is sitting on my desk at the shop...

grass4gas
10-04-2010, 06:04 AM
I'm surprised David hasn't chimmed in by now. He usually is pretty quick to respond to posts such as this.

Good luck

MnLefty
10-04-2010, 06:25 AM
From the LS Ride On Manual

"Use 10-30 oil, or 0-30 synthetic for colder starting conditions"

grassmasterswilson
10-04-2010, 07:04 AM
From the LS Ride On Manual

"Use 10-30 oil, or 0-30 synthetic for colder starting conditions"

Thanks MnLefty! You rock!

lush&green
10-04-2010, 09:16 AM
Just talked to the repair center. It is not the starter but the hydro pump...We had fluid in the main tank. Just relayed the info to LS and they say the reservoir does not have to have any fluid in it to run as long as the main tank has fluid. Just look at the glass eye on the main tank.

LawnSolutionsCP
10-04-2010, 03:47 PM
Yes, 10W30

David