PDA

View Full Version : Echo PAS-265


Happy Frog
10-06-2010, 12:39 PM
One of my Echo PAS-265 (I used mostly as trimmer) was losing it's power and started to run rough at high rpm.

- Checked the air filter: oh crap! this thing is covered in oil and dirt (much more than I ever seen one)
- Put a new air and gas filter, no dice
- checked the spark plug: looked good but replaced it anyway just to try it out, no luck there.
- Put some Sea-foam in the gas (usually does wonder for me) but that did not solve the problem and after a few more hours, I really felt the lack of power. The engine is sputtering like crazy at full throttle.
- Removed the air filter and ran the engine to see why the air filter was so dirty in the first place and I can see quite a bit of gas spitting out of the cab when at full throttle.
- Removed the exhaust and checked the exhaust window by the piston: I can see a small ridge of carbon deposit (about one tenth of an inch) on one side which I remove which a plastic tooth pick (was kind of soft and greasy)
- Put back the exhaust: Problem solved, the engine runs like a champ! :dancing:

The little ridge of carbon was creating enough back pressure on the intake to prevent the carb from working properly and make it spit gas/oil mix on the air filter.

I run Amsoil Saber at 80:1 instead of 100:1 and that may have contributed to the carbon deposit but I only cleaned it once before (because the manual asked for it) and found almost nothing to clean when I did.

:hammerhead: Lesson learned: check the exhaust window if the engine seems to lose power or the air filter gets oily. It does not take much for these EPA/CARB engines to lose power because of back pressure in the carb intake.

After three years, those PAS-265 are still running strong! :weightlifter:
:drinkup:

Alan0354
10-06-2010, 04:35 PM
How is the piston look, still look new or look worn out? Around how many hours you have on? I know you are about the first one start using the 265 here over 3 years ago.

Happy Frog
10-06-2010, 04:55 PM
How is the piston look, still look new or look worn out? Around how many hours you have on? I know you are about the first one start using the 265 here over 3 years ago.

Piston looked good. No scratches or sign of heavy wear. Top of piston looked pretty clean too.

I have ran them a few hundreds of hours each, hard to say exactly. Probably around 400 hours or so.

They run as good as new. only changed the fuel filters once and air filters three or four times.

Same E3 spark plug since new (put back the old spark plug on the unit I fixed).

I run them with the articulated hedger attachment to clean up the overgrown lake bank twice a year before running the Dually over and the engine barely slows down at full throttle...

Only down side is the weight. They get really heavy after a few hours.

ed2hess
10-06-2010, 06:50 PM
The exhaust have to be cleaned about every 6 months. And....there is a little ridge of deposit that gets just above the spark plug that needs to be knocked off. If you turn the crank over with the plug out you can feel it hit that ridge..not good to leave. We are are in the third year with thise machines under heavy use and I think the 265 is a winner. But you better keep that air filter clean. They have a new version of the filter that has black ribs.

Alan0354
10-06-2010, 08:06 PM
Look like Echo have a real winner!!! Three years speak louder than anything else.


AND there are people keep saying Echo are cheap stuffs!!! To be honest, I would worry about Shindaiwa dragging down Echo more so than the other way.

To clarify, I am not an Echo fan and I own two pieces of Shindaiwa and one Echo. But reading posts for over three years tell a lot about how good Echo is.