View Full Version : Need help troubleshooting my truck wiring

11-09-2010, 09:01 PM
Have isolated the problem to the truck wiring. I have running lights but no brake lights or turn signals. Earlier the left turn signal and brake light was working, now theres nothing. truck is a 1999 f150 with an aftermarket hitch and wiring harness with 4-pin connector. Fuse? Broken wire? crossed wire? I know it was working fine a few weeks ago. Thanks for any help.

11-09-2010, 10:39 PM
Now im starting to blow out fuses..and im afraid i might have burnt up a wire. how does something this simple get so complicated?

11-15-2010, 08:00 PM
I had the same problem on my chevy and spent hours trying to diagnose the problem between fuses and such. It turned out that I had stepped and unplugged the brake switch cable when jumping into the truck one day. Look under your brake peddle for the cables and the switch, you may have just unplugged it on accident.

11-15-2010, 09:21 PM
Thanks, I will have to check it in the morning, i hope thats what it is, otherwise ill be putting in a new green wire from the fuse box under the hood all the way to the rear bumper. I hope its not a can of worms im getting into. Thanks again for the help.

11-15-2010, 09:39 PM
get a test light if you dont already have one save you alot of time

11-15-2010, 09:45 PM
test light-no power to pin #4.

11-15-2010, 10:16 PM
next check the fuse block, if its got power then it has to be the wire like you said, should be pretty simple

i would try to get a wiring diagram for your truck to

11-15-2010, 11:21 PM
Alright. Will check the fuse box tomorrow as well. Would the wiring diagram help since the hitch and wiring for the hitch are aftermarket?

11-16-2010, 10:38 PM
the wiring diagram would just help with the wires coming from the truck, not the wiring harness