PDA

View Full Version : Help ASAP my Ford won't shut off!


Chop Stuff Up
01-02-2011, 08:18 PM
05 Econoline 350... It's running and after I turn the ignition off and pull the key out, it just keeps running! Appreciate any help! To make matters worse it won't shift out of park!

Puddle of Oil
01-02-2011, 08:22 PM
rip the sparks out!

Chop Stuff Up
01-02-2011, 08:25 PM
Each plug has a coil and they are a b**** to get to!

koster_irrigation
01-02-2011, 08:33 PM
banana in the tailpipe?

MarcSmith
01-02-2011, 08:33 PM
pull the fuse on the fuel pump...

Chop Stuff Up
01-02-2011, 08:34 PM
closed up the intake hose and she shut off, wow that was interesting. Dash service lights are still on though.

MarcSmith
01-02-2011, 08:35 PM
if it wont shift out of park, then the brake interlock switch could be faulty. but if your turn the ignition off and it doen't shut off then if venture to guess that your ignition switch is bad... if your ignition switch is bad it could also be causing the "no shift out of park" issue

Puddle of Oil
01-02-2011, 08:36 PM
oops, you posted while i was typing.

MarcSmith
01-02-2011, 08:36 PM
pullthe positive terminal it will all shut off the lights..

Chop Stuff Up
01-02-2011, 08:38 PM
pull the fuse on the fuel pump...

Would've tried this if the stupid fuses were labeled lol. I remember when the fuel pump died on my 98 Ford and the thing still kept running. It would only idle though.

Darryl G
01-02-2011, 08:40 PM
Sounds like you've got a Poltergeist! I'll have to go check our VW van and see if the one that lives in there has moved out and relocated, lol.

Chop Stuff Up
01-02-2011, 08:41 PM
if it wont shift out of park, then the brake interlock switch could be faulty. but if your turn the ignition off and it doen't shut off then if venture to guess that your ignition switch is bad... if your ignition switch is bad it could also be causing the "no shift out of park" issue

It has had the "no shift out of park" Issue for a while. I have to shift it into neutral before I start it, then shift to drive. Once I go back to park I have to shut it off and go to neutral, then start it again. Ford says I need a whole circuit board it isn't the switch. Ugh!

MarcSmith
01-02-2011, 09:09 PM
It has had the "no shift out of park" Issue for a while. I have to shift it into neutral before I start it, then shift to drive. Once I go back to park I have to shut it off and go to neutral, then start it again. Ford says I need a whole circuit board it isn't the switch. Ugh!dig deep...electrical gremlins are usually costly..