PDA

View Full Version : dead annuals


MPhillips
09-16-2002, 10:25 AM
I'm not really up on shrubbery applications, hoping you guys can educate me a little.

Have a large commercial property that I sub the shrubbery fertilizing and pesticide applications to...the oldest and most respected guy in town. Mainly needlepoint hollies, boxwoods, otto luchens, crepes and mamosas.

Had an application 10 days ago, after 7 days 40 feet of petunias, and 2 adjoining boxwoods were dead... they'd been fairly healthy prior to that I think but I really hadn't checked them out thoroughly. Adjoining plants to them appear fine with no evidence of an infestation. No other plants on the site appear to have been adversly affected.

Could an application have done this?

tremor
09-16-2002, 11:13 AM
Call the applicator guy & look at the plants without the property manager if that's possible.

Stale tank mix in the hose "might possibly" have caused some phytotoxicity. But the problem could have been caused by something else.

If this guy is as tenured as he sounds, you'll probably get his full cooperation & interest in solving the problem. Just make sure to give him the courtesy of your honest & forthright communication. In other words, give him a call.

A good plant pathologist at your local ag station or hort school would be of help daignosing the problem.

Were any other trades people working at the sight in the 2 or 3 days ajacent to the date in question? 7 days is a long time to see phyto from an app. Or was it that long before you saw the place again, & the damage was evident sooner? 1-3 days is more like the phto scenario I would expect.

Good luck & let us know the verdict.

Steve

MPhillips
09-16-2002, 11:19 AM
tremor, like an idiot I had the dead material removed and disposed of during the weekly visit...I check with the guy though and let you know...thanks