PDA

View Full Version : Grasshopper 718d gemini motor problem


sswest
03-06-2011, 02:23 PM
I have a '93 718d with approx 850 hrs. The left wheel motor is losing power in reverse. Any solution to this problem. Also, is there any way to rebuild the deck undercarriage, ie the discharge metal rings. It won't discharge the clippings. Thanks Steve

ALC-GregH
03-06-2011, 02:53 PM
Discharge metal rings? ;);););););)

sswest
03-06-2011, 04:08 PM
The metal under the deck that forms a ring or circle around the blades. Mine over the course of use has been damaged. Any way to rebuild these?

Mowingman
03-06-2011, 05:06 PM
Cut the old baffles out and weld in new ones. you must be in sandy soil if they have worn out.

sswest
03-06-2011, 06:55 PM
Thanks mowingman. I know you know Grasshoppers well, so is there a answer to the loss of power to the wheel motor, other than replacement? Thanks

Mowingman
03-06-2011, 07:41 PM
First, I would check that the idler pulley on the belt that runs that side. Is it tensioned properly so the belt is not slipping? The pulley could be worn out, or the tension spring may be bad, or the pivot point may be frozen up. All the aforementioned are common problems as these machines get old. Is the belt still good and not stretched out?
I can not remember if your machine has the filter screen, or the actual spin-on filter. Whichever it has, I would change that filter/screen. also, check oil level, and maybe go ahead and do an oil change in the hydro unit.
Make sure the free-wheel relief valve is fully closed also. If not, you could be loosing presure there.
Check all this before going into panic mode about buying a new replacement hydro unit.:):)

sswest
03-06-2011, 09:12 PM
Thanks, that sounds like all good suggestions to check. It has the spin on filter by the way. If it turns out motor/pump is bad, where is best place to get another one? Do they rebuild these? Thanks again..

sswest
03-06-2011, 10:01 PM
Thanks, that sounds like all good suggestions to check. It has the spin on filter by the way. If it turns out motor/pump is bad, where is best place to get another one? Do they rebuild these? Thanks again..

Mowingman
03-06-2011, 10:14 PM
The only place I know of to get one is from Grasshopper. New ones run about $1000.00, or maybe more, installed. SOMETIMES Grasshopper has a few rebuilt ones at the factory. They are a few hundred cheaper. However, they are only warrantied to work when you install it. If it fails in a month, you are on your own. They do not have these very often.
I have talked to a large Eaton hydraulics repair shop about rebuilding these things. They were not excited about doing it, but said they could. The price was close to new price, and they also, would not offer any kind of warranty, except it would work when installed.
One more thing to check is that the control rod from the steering lever is fully engaging the trans. If the joints get worn and get slack in them, just a little slack can cause trans to not fully engage.
Good luck.