PDA

View Full Version : Silverado remote starter problem?


mowerbrad
03-10-2011, 03:52 PM
I have been very happy with my truck so far but I have found one small problem. Every now and then when I use my remote starter for my truck, it won't actually start. I'll do everything correctly, lock the truck and then hold the remote start button down, but maybe 1 out of every 10 times or so the truck will turn over but not start. I'll try to remote start it again, but nothing the second time. So immediately after, I will go out and start the truck with my key. When I start it with the key (after experiencing the problem) it will start but sputter out almost immediately. No engine lights come on, so I start it a second time with the key and it works PERFECT. Onstar wasn't able to find any codes when they did a vehicle scan and no engine lights have yet come on. Once I start it, it'll drive like new...not quite sure what it is.

My truck is about to go in for an oil change in the next couple weeks, so I will probably have the dealer check into it or see if they have seen this problem before.

Anyone have any ideas?

GreenI.A.
03-11-2011, 12:20 AM
only thing I can think is maybe one of the safeties is failing. like one of the ones that shuts off the ignition if you touch the brake, with out the key in the igntion, or the ones that make sure the truck is in park.

ParkWelding
03-11-2011, 09:28 AM
Passlock anti theft problem most likely. That would be the most common reason for a GM of that year to crank but not run when trying to start with the key, particularly after a failure to start with the remote start. That also would be the one of the two most likely reasons for said vehicle to crank and fail to start with remote start on an intermittent basis. Most common in my experience is a bad tach connection to the vehicle. That would not likely give you the crank-sputter-fail to start with the key however.

What kind of RS and security bypass are installed in the truck?

mowerbrad
03-11-2011, 09:41 AM
Passlock anti theft problem most likely. That would be the most common reason for a GM of that year to crank but not run when trying to start with the key, particularly after a failure to start with the remote start. That also would be the one of the two most likely reasons for said vehicle to crank and fail to start with remote start on an intermittent basis. Most common in my experience is a bad tach connection to the vehicle. That would not likely give you the crank-sputter-fail to start with the key however.

What kind of RS and security bypass are installed in the truck?

It's all the factory/GM remote start system. Not quite sure what type of bypasses are on the truck though.

But you have at least given me an idea of what it could be. This isn't a big problem, is it?

When it sputters out, it basically sounds like when a lawn mower that runs out of gas. The sputtering maybe lasts for 3 seconds, then shuts off.

bmc1025
03-11-2011, 12:09 PM
does the security light stay on when it fails to start with the key?

STIHL GUY
03-11-2011, 07:27 PM
hmmm i have an 05 2500HD with remote start and have never had this problem. mine instead of holding the button down i push it twice and the truck will start. it will start if it is locked or unlocked

mowerbrad
03-11-2011, 10:10 PM
does the security light stay on when it fails to start with the key?

Didn't notice any lights when it didn't start with the key. I'll have to pay closer attention, next time to make sure that no lights stayed on, but I really didn't notice any.

After the truck is started with the remote starter, you can't move the shifter until the key is in the truck. You can apply the brake all you want, but it locks the shift lever in the "park" postion.

I would imagine that if it was a security feature causing the truck to shut down, it would shut down smoothly like when you turn it off with the key. But since it is more of a "sputter", I think that there has to be something more to it...the truck turns over but doesn't start with the remote start, then has the sputter out issue when you first try and start it with the key, after that its fine. So I have to think that the problem is with the remote start system.

I've searched some of the truck forums and haven't been able to find anything about this problem.

ParkWelding
03-12-2011, 12:09 AM
I don't recall what kind of units are factory installed in the GM's. Might be a dealer thing to work on them. I would not use the RS till its straightened out. If it is a Passlock issue, which I would almost guarantee, it COULD cause the vehicle not to start for a long period of time. Sucks to be stuck cause of a convenience feature on your vehicle.