PDA

View Full Version : Echo 280T problem


kietsterz
04-26-2011, 06:08 PM
I have always using echo products. My echo 280t keep shut off on me. I have replace the short block but they still have the same problem. I think it is the carb problem but do not know how to adjust it. Would you guy help me out with this matter. Thank you.:cry:

Runner
04-26-2011, 08:59 PM
It could be several things. A likely culprit for these machines? (I have several Echos) The fuel cap isn't venting enough. It may need a different type of cap (venting). I've seen this several times.

pressley10r
04-26-2011, 10:03 PM
My echos frequently have carb probs, I would look into that first

Thunderhead
04-26-2011, 10:44 PM
It could also be the ignition coil, or something electrical. I think it carries a lifetime warranty though. I'm no mechanic but we do need more information from you...

ed2hess
04-27-2011, 08:01 PM
These echo units have vents on them and seldom fail in this manner. The carb has two adjusment needles and both are coverec with a plastic cap down in a hole that you can hardle see into. I take mine to dealer to get those out but have ordered the tool and will post picture when I get it. Does teh unit die in all positions ore whe you rotate it? What happened to warrant a short block? Unfortunately this model didn't have good enough filters and dust is causing ring failures.

kietsterz
04-29-2011, 09:48 PM
Look like the unit run good when it's not hot. After two or three house, the unit just shut down. And then a little while later the machine running good again. Thanks for the info guy.

Merkava_4
04-29-2011, 09:57 PM
What you're describing sounds like a coil problem.

topsites
04-29-2011, 09:59 PM
magneto ignition module